Certbot-dns-linode macOS install instructions don't work

My domain is: cdn.dsheppard.ca

I ran this command:

brew install -linode

(This is the exact command that you are told to run when you specify other/macOS/wildcard at certbot.eff.org, select "wildcard" and want to use Linode as your DNS provider. The documentation uses brew install -cloudflare as an example, which I tried by pasting the exact command text from the example, but that also does not work.)

It produced this output:

Usage: brew install [options] formula|cask [...]
(followed by the usual Homebrew help text)
Error: Invalid usage: This command requires at least 1 formula or cask argument.

Running brew install -cloudflare, directly copied and pasted from the exact example provided by certbot.eff.org's documentation, produces:

Error: ambiguous option: -cloudflare

My web server is (include version): None, I'm running this locally and will upload certs to my server.

The operating system my web server runs on is (include version): Local box is on macOS Monterey, server operating system is irrelevant. I can't even get to the point where the server OS matters because I can't install the Linode DNS plugin.

My hosting provider, if applicable, is: Linode

I can login to a root shell on my machine (yes or no, or I don't know): yes, on both my Linode server and on macOS

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 1.26.0

The instructions are currently wrong. DNS plugins are not available from Homebrew.

In the meantime, you can install the plugin using:

$(brew --prefix certbot)/libexec/bin/pip install certbot-dns-linode

Unfortunately it won't survive through a brew upgrade.

The other option is to install Certbot via pip rather than Homebrew, which should work on macOS.


This one has worked flawlessly! Now all I have to do is never update anything. :slight_smile:

I suspect most people will try to install with Homebrew, since that's the default suggestion from the site. Is there a sub-project to make brew install -cloudflare work as expected, update the documentation with the pip approach, or make something like brew install certbot-dns-cloudflare work as expected?

There is a rather old issue about this at Make all plugins available via Homebrew · Issue #5680 · certbot/certbot · GitHub.

The Homebrew packages are maintained by external volunteers, rather than the Certbot team. There would need to be a conversation about how packaging of the plugins could be achieved. Sometimes there is trickiness with dependencies.

The packages maintained directly by the Certbot team are the snap, Docker images, and pip packages.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.