Certbot (debian 10) broke debian11/nginx setup [mistake, nothing wrong with certbot]

I wasn't paying attention and accidentally just followed install directions for Debian 10 and nginx when in reality my server is running Debian 11 and nginx. My setup was working fine previously over http after installing certbot all http or https requests to the site just timed out. I want to uninstall certbot so I ran
sudo certbot delete and commented out all the changes that certbot noted in my nginx.conf file. What else do I have to do so my site is working via http again ?

PS I also run an extremely similar setup on another server for a different domain but it uses Debian 10 and certbot runs perfectly. So at this point really just want to UNDO my whatever certbot did to my server.

Actually it seems like browser behavior I wasn't aware of. In two browsers I already tried opening the https version of the site, it will not revert back to http, even if specifying http protocol and/or port. However, trying to open the site using http on a third browser or with private browsing mode works.

In any case, if I missed any other important steps in certbot uninstall process / cleanup please let me know as this seems to be missing from user guide.

Did you restart nginx after removing all https config? Because that should be sufficient. There is no need to remove certs or certbot. If nginx has no https config then none can happen.

If you supply the domain name we can give better advice

EDIT: Oh, and welcome to the community @noob

EDIT2:

My first guess is that you hadn't opened port 443 once you configured nginx for https. Again, if you provide the domain name we can check that for you. Or, try an SSL Checker site like this one

5 Likes

Thanks a lot! Totally forgot about the firewall sitting in front of my server that was blocking 443. :upside_down_face: Debian 11 was just a red herring.

3 Likes