Certbot couldn't find my IP for my NOIP domain


#1

I successfully deployed a website on my Raspberry PI 2 (you can check it: http://tritham.myvnc.com). The domain name and dns service is provided freely by NOIP.COM. Ports 80 and 443 are forwarded on my router. But I got an error, namely “No valid IP addresses found for tritham.myvnc.com” when I tried to configure HTTPS for the site using CERTBOT.
Please help!

My domain is: tritham.myvnc.com

I ran this command: sudo certbot --authenticator webroot --installer apache

It produced this output:

….
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. tritham.myvnc.com (http-01): urn:acme:error:unknownHost :: The server could not resolve a domain name :: No valid IP addresses found for tritham.myvnc.com

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: tritham.myvnc.com
    Type: unknownHost
    Detail: No valid IP addresses found for tritham.myvnc.com

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A record(s) for that domain
    contain(s) the right IP address.

My web server is (include version): Apache2

The operating system my web server runs on is (include version): Raspbian Stretch

My hosting provider, if applicable, is: on my own Rasberry PI

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No


#2

tritham.myvnc.com doesn’t have a public IP address right now. It’s 100.73.43.178, a private IP address reserved for Carrier-Grade NAT. (Similar to, but different from, the private IP ranges like 192.168.x.y.)

You need a public IP, which may require contacting your ISP…


#3

For more info about the type of IP address @mnordhoff is referring to, see: https://en.wikipedia.org/wiki/IPv4_shared_address_space


#4

Thank you very much. I read some books on TCP/IP but none of them mention this range of IP addresses. This is very helpful information for me. Thanks again!


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.