Certbot connection refused (please help)

Hi, Im having trouble seting up certbot. I have a my application in a docker compose file. Everything runs fine locally but once i connect certbot using this tutorial: Docker-Compose for Django and React with Nginx reverse-proxy and Let’s encrypt certificate | Django and React Tutorials
I run into an issue. Any help would be highly appreciated!

My domain is: batwaactivities.com

I ran this command: sudo ./init-letsencrypt.sh

It produced this output:
ertbot failed to authenticate some domains (authenticator: webroot). The Certificate Authority reported these problems:
Domain: batwaactivities.com
Type: connection
Detail: Fetching http://batwaactivities.com/.well-known/acme-challenge/uZKdpRoPvxVxbKZ8K1hvKWgA5FFppQGzT6NjH7u1Kpc: Connection refused

My hosting provider, if applicable, is: digitalocean

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): latest

1 Like

You need to open tcp port 80 (used by http) so that http validation can be performed.


In other words, you need a working website before you try to secure it.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.