Certbot challenges recently failing

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: reuelalvarez.com

I ran this command: sudo certbot certonly --manual -d reuelalvarez.com --dry-run -v

It produced this output: Challenge failed for domain reuelalvarez.com

My web server is (include version): nginx/1.21.5

The operating system my web server runs on is (include version): macos 10.13.6

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):1.22.0

my certificates were up for renewal today and i tried renewing them but kept getting the above errors w/ the renew command. they'd been working for years. i deleted the certs using certbot delete and i'm still getting errors. i tried manually creating the challenge files and i'm still getting the verification error. i verified myself that the files and contents are correct and accessible externally. i've got port forwarding on for this ip on 80 and 443. ive literally changed nothing and this just stopped working.

Hello and welcome to the community forum @brute-force

Right now your server is not accessible from the public internet. See

Please show the related error message(s) you get when it fails. It is not helpful to just say it did not work. You are probably getting different errors as you tried things.

For example, if you deleted the certs that nginx is using then nginx may no longer start. It needs some kind of cert file in an https server block. Deleting certs is rarely a solution to renewal failures.


yes, i deleted it after several failures and i couldn't find a solution. nginx does start since i disabled the https server. anyway, i think my isp may be blocking port 80. i am checking w/ them now.

it was my isp. i had them enable it and everything works again.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.