Certbot-auto cannot find python


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: bastion.aouk.co.uk

I ran this command:
./certbot-auto certonly --agree-tos --register-unsafely-without-email --rsa-key-size 4096 --webroot --webroot-path /var/www/html --no-bootstrap -d bastion.aouk.co.uk -d www.bastion.aouk.co.uk

It produced this output:
WARNING: couldn’t find Python 2.6+ to check for updates.
Creating virtual environment…
Cannot find any Pythons; please install one!

My web server is (include version):
Server version: Apache/2.2.15

The operating system my web server runs on is (include version):
CentOS release 6.9 (Final)

My hosting provider, if applicable, is:
Amazon Web Services

I can login to a root shell on my machine (yes or no, or I don’t know):
yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no

I have both python 2.6.6 and python 2.7, both which seem to work fine. Path for python 2.6.6 is /usr/bin/python


#2

I solved the problem myself. Running ./certbot-auto and then with all the flags afterwords did not work. I then ran ./certbot-auto by itself, and it was able to install the missing python plugins.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.