Certboot - port 442

I have a nextcloud server / apache running at port 442 . (443 is occupied by other services)
The server is only listening to port 442 When I send file links for other to downlod files, they get warnings about the self signed certificate currently in use, therefore I want to use let’s encrypt to avoid this warnings.
The server is accessible from https://nextclud.exampledomain.com:442 and listens only to port 442
Except for the current self signed certificate, this works fine.

Can certboot be used for installing a certificate on port 442 and also have successful renewals ?

You need access to port 80 to obtain or renew a certificate. For example, you can run certbot on a server where Apache is listening on port 80, or where port 80 is free and certbot itself can listen there (with --standalone). If port 80 is not available to you, the only other option is to use the DNS challenge.

Once you’ve obtained the certificate you can install and use it on any port (except 80 if you’re using that for renewals), so 442 should be no problem.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.