Cert not renewing On syno Nas

Hi all.

I’m not able to renew the certificate on my 2 Synology Nas. I get back a “operation failed, log in back and try again”. I do have the relevant ports open and the certificate was always renewing itself.

Any help will be much appreciated.

Thank you

My domain is: gabstech.it

I ran this command: N/A

It produced this output: N/A

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: OVH

I can login to a root shell on my machine (yes or no, or I don't know): don’t know

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): N/A

1 Like

Hi @kadaj81

that's expected, your configuration is buggy, see https://check-your-website.server-daten.de/?q=gabstech.it

http + non-www + /.well-known/acme-challenge/random-filename redirects to the www version, then to /.

But / doesn't have your validation file.

Remove these wrong redirects subdirectory -> /.

1 Like

Hi @JuergenAuer and thank you so much for the reply.

I’m kind of a noob, but if you direct me,I’m sure i will be able to sort it out.

How do i remove the redirect? Where? In my domain? What field should i look for?

I’m very very sorry to bother you with this and probably wasting your time, but i would extremely appreciate your help.

Thank you again.

2 Likes

You have created that buggy configuration.

So you know what you have to change.

A noob wouldn't have such a configuration.

@JuergenAuer

If i knew it what was wrong, I would have tried to sort it out myself. I am a noob, just bought a domain on OVH, used the DDNS built in in the synology and created 2 DyN host. did not create any record or DNS zone. I did not touch that because I have no clue.
I just wanted not to use the ddns service synology.me,and make my nas more secure using a domain.

Sorry to have bothered you.

Thanks anyway.

2 Likes

How should that work?

Calling http://www.gabstech.it/ there is a standard OVH page, not a Synology page. So your domain provider answers, not your local Synology.

The A record of your domain name must point to your DDNS domain name (may be via CNAME, I have no idea how that works).

So you use another domain name.

Please read a lot of basics:

and

If you want to use http validation, a working port 80 / http is required. Port 6501 is unrelevant.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.