Cert installation showing error with Acme authetication

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:dniservicesllc.com

I ran this command:certbot-auto certonly -d www.dniservicesllc.com -d dniservicesllc.com

It produced this output: The following errors were reported by the server:

Domain: dniservicesllc.com
Type: unauthorized
Detail: Invalid response from
http://dniservicesllc.com/.well-known/acme-challenge/_EJzRW73u8qHbvzB7JguHMXeW3NTeaOcwqyCIBbmg40
[66.193.196.68]: “\r\n404 Not
Found\r\n<body bgcolor=“white”>\r\n

404
Not Found

\r\n

My web server is (include version): nginx

The operating system my web server runs on is (include version): ubuntu

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Hi @yazar

there is no information about your authentication method. What’s the content your certbot config file?

Checking your domain there is a nginx - https://check-your-website.server-daten.de/?q=dniservicesllc.com

What says

nginx -T

pasting the Nginx -T result,
root@dniservicessvr01:/var/www/html/.well-known/acme-challenge# nginx -T
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful

configuration file /etc/nginx/nginx.conf:

user www-data;
worker_processes auto;
pid /run/nginx.pid;
include /etc/nginx/modules-enabled/*.conf;

events {
worker_connections 768;
# multi_accept on;
}

http {

##
# Basic Settings
##

sendfile on;
tcp_nopush on;
tcp_nodelay on;
keepalive_timeout 65;
types_hash_max_size 2048;
# server_tokens off;

 server_names_hash_bucket_size 64;
# server_name_in_redirect off;

include /etc/nginx/mime.types;
default_type application/octet-stream;

##
# SSL Settings
##

ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
ssl_prefer_server_ciphers on;

##
# Logging Settings
##

access_log /var/log/nginx/access.log;
error_log /var/log/nginx/error.log;

##
# Gzip Settings
##

gzip on;

# gzip_vary on;
# gzip_proxied any;
# gzip_comp_level 6;
# gzip_buffers 16 8k;
# gzip_http_version 1.1;
# gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;

##
# Virtual Host Configs
##

include /etc/nginx/conf.d/*.conf;
include /etc/nginx/sites-enabled/*;

}

#mail {

# See sample authentication script at:

# http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript

# auth_http localhost/auth.php;

# pop3_capabilities “TOP” “USER”;

# imap_capabilities “IMAP4rev1” “UIDPLUS”;

server {

listen localhost:110;

protocol pop3;

proxy on;

}

server {

listen localhost:143;

protocol imap;

proxy on;

}

#}

configuration file /etc/nginx/modules-enabled/50-mod-http-geoip.conf:

load_module modules/ngx_http_geoip_module.so;

configuration file /etc/nginx/modules-enabled/50-mod-http-image-filter.conf:

load_module modules/ngx_http_image_filter_module.so;

configuration file /etc/nginx/modules-enabled/50-mod-http-xslt-filter.conf:

load_module modules/ngx_http_xslt_filter_module.so;

configuration file /etc/nginx/modules-enabled/50-mod-mail.conf:

load_module modules/ngx_mail_module.so;

configuration file /etc/nginx/modules-enabled/50-mod-stream.conf:

load_module modules/ngx_stream_module.so;

configuration file /etc/nginx/mime.types:

types {
text/html html htm shtml;
text/css css;
text/xml xml;
image/gif gif;
image/jpeg jpeg jpg;
application/javascript js;
application/atom+xml atom;
application/rss+xml rss;

text/mathml                           mml;
text/plain                            txt;
text/vnd.sun.j2me.app-descriptor      jad;
text/vnd.wap.wml                      wml;
text/x-component                      htc;

image/png                             png;
image/tiff                            tif tiff;
image/vnd.wap.wbmp                    wbmp;
image/x-icon                          ico;
image/x-jng                           jng;
image/x-ms-bmp                        bmp;
image/svg+xml                         svg svgz;
image/webp                            webp;

application/font-woff                 woff;
application/java-archive              jar war ear;
application/json                      json;
application/mac-binhex40              hqx;
application/msword                    doc;
application/pdf                       pdf;
application/postscript                ps eps ai;
application/rtf                       rtf;
application/vnd.apple.mpegurl         m3u8;
application/vnd.ms-excel              xls;
application/vnd.ms-fontobject         eot;
application/vnd.ms-powerpoint         ppt;
application/vnd.wap.wmlc              wmlc;
application/vnd.google-earth.kml+xml  kml;
application/vnd.google-earth.kmz      kmz;
application/x-7z-compressed           7z;
application/x-cocoa                   cco;
application/x-java-archive-diff       jardiff;
application/x-java-jnlp-file          jnlp;
application/x-makeself                run;
application/x-perl                    pl pm;
application/x-pilot                   prc pdb;
application/x-rar-compressed          rar;
application/x-redhat-package-manager  rpm;
application/x-sea                     sea;
application/x-shockwave-flash         swf;
application/x-stuffit                 sit;
application/x-tcl                     tcl tk;
application/x-x509-ca-cert            der pem crt;
application/x-xpinstall               xpi;
application/xhtml+xml                 xhtml;
application/xspf+xml                  xspf;
application/zip                       zip;

application/octet-stream              bin exe dll;
application/octet-stream              deb;
application/octet-stream              dmg;
application/octet-stream              iso img;
application/octet-stream              msi msp msm;

application/vnd.openxmlformats-officedocument.wordprocessingml.document    docx;
application/vnd.openxmlformats-officedocument.spreadsheetml.sheet          xlsx;
application/vnd.openxmlformats-officedocument.presentationml.presentation  pptx;

audio/midi                            mid midi kar;
audio/mpeg                            mp3;
audio/ogg                             ogg;
audio/x-m4a                           m4a;
audio/x-realaudio                     ra;

video/3gpp                            3gpp 3gp;
video/mp2t                            ts;
video/mp4                             mp4;
video/mpeg                            mpeg mpg;
video/quicktime                       mov;
video/webm                            webm;
video/x-flv                           flv;
video/x-m4v                           m4v;
video/x-mng                           mng;
video/x-ms-asf                        asx asf;
video/x-ms-wmv                        wmv;
video/x-msvideo                       avi;

}

configuration file /etc/nginx/sites-enabled/default:

server {
root /var/www/html;
index index.html index.htm index.nginx-debian.html index.php;

    server_name dniservicesllc.com www.dniservicesllc.com;

location ^~ /.well-known/acme-challenge/ {
default_type “text/plain”;
alias /var/www/html/.well-known/acme-challenge/;
}
}

#location / {

try_files $uri /index.html index.php ;

#}

    #location / {
     #       try_files $uri $uri/ =404;
   # }

location ~ .php$ {

include snippets/fastcgi-php.conf;

fastcgi_pass unix:/var/run/php/php7.2-fpm.sock;

}

location ~ /.ht {

deny all;

}

#}

listen [::]:443 ssl ipv6only=on; # managed by Certbot

listen 443 ssl; # managed by Certbot

ssl_certificate /etc/letsencrypt/live/dniservicesllc.com/fullchain.pem; # managed by Certbot

ssl_certificate_key /etc/letsencrypt/live/dniservicesllc.com/privkey.pem; # managed by Certbot

include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot

ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

#}
#server {

if ($host = www.dniservicesllc.com) {

return 301 https://$host$request_uri;

} # managed by Certbot

if ($host = dniservicesllc.com) {

return 301 https://$host$request_uri;

} # managed by Certbot

listen 80;

listen [::]:80;

server_name dniservicesllc.com www.dniservicesllc.com;

return 404; # managed by Certbot

#}

Also please let me know how to check certbot config file?

Also getting this error while running command,
root@dniservicessvr01:/var/www/html/.well-known/acme-challenge# certbot certonly --standalone --preferred-challenges http -d dniservicesllc.com -d www.dniservicesllc.com
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator standalone, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for dniservicesllc.com
http-01 challenge for www.dniservicesllc.com
Cleaning up challenges
Problem binding to port 80: Could not bind to IPv4 or IPv6.
root@dniservicessvr01:/var/www/html/.well-known/acme-challenge#

You have two blocks with

Merge these in one port 80 server block, restart your nginx, then again

nginx -T

Use ` three times, then a return, then the content, return, again three (not possible to show that).

server {
listen 80 default_server;
server_name dniservicesllc.com www.dniservicesllc.com;
root /var/www/html;
index index.html index.htm index.nginx-debian.html index.php;

location ^~ /.well-known/acme-challenge/ {
default_type “text/plain”;
alias /var/www/html/.well-known/acme-challenge/;
}
}

#location / {

try_files $uri /index.html index.php ;

#}

    #location / {
     #       try_files $uri $uri/ =404;
   # }

location ~ .php$ {

include snippets/fastcgi-php.conf;

fastcgi_pass unix:/var/run/php/php7.2-fpm.sock;

}

location ~ /.ht {

deny all;

}

#}

listen [::]:443 ssl ipv6only=on; # managed by Certbot

listen 443 ssl; # managed by Certbot

ssl_certificate /etc/letsencrypt/live/dniservicesllc.com/fullchain.pem; # managed by Certbot

ssl_certificate_key /etc/letsencrypt/live/dniservicesllc.com/privkey.pem; # managed by Certbot

include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot

ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

#}
#server {

if ($host = www.dniservicesllc.com) {

return 301 https://$host$request_uri;

} # managed by Certbot

if ($host = dniservicesllc.com) {

return 301 https://$host$request_uri;

} # managed by Certbot

listen 80;

listen [::]:80;

server_name dniservicesllc.com www.dniservicesllc.com;

return 404; # managed by Certbot

#}

I have merged the port for both www and main domain still its showing the same error?
Pasting the error,

root@dniservicessvr01:/var/www/html/.well-known/acme-challenge# certbot certonly --standalone --preferred-challenges http -d dniservicesllc.com -d www.dniservicesllc.com
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator standalone, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for dniservicesllc.com
http-01 challenge for www.dniservicesllc.com
Cleaning up challenges
Problem binding to port 80: Could not bind to IPv4 or IPv6.

You didn’t. There are two blocks with

server_name dniservicesllc.com www.dniservicesllc.com

Every combination of port and server name must be unique.

Only one block is allowed.

can you send me any reference link any?

Also I am getting the below error while trying with nginx as option,

Failed authorization procedure. dniservicesllc.com (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://dniservicesllc.com/.well-known/acme-challenge/C5Kg2OFfrET9MOE7HtRDwjbQhDHPaUkm5pyi5_vXb7c [66.193.196.68]: “\r\n404 Not Found\r\n<body bgcolor=“white”>\r\n

404 Not Found

\r\n
”, www.dniservicesllc.com (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://www.dniservicesllc.com/.well-known/acme-challenge/wxgrn65fePitRtxmp_yVMhZnu4NW_61qIHHHSvEKwks [66.193.196.68]: “\r\n404 Not Found\r\n<body bgcolor=“white”>\r\n

404 Not Found

\r\n

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.