Cerbot-auto v0.10.1 - Segmentation Fault


#1

Please fill out the fields below so we can help you better.
I was using certbot-auto v.0.9.x successfully. Now with version 0.10.1 it seg-faults.

My domain is: boriel.com

I ran this command: ./certbot-auto

It produced this output:
I’m also having a segmentation fault with cert-bot auto on ubuntu 16.04
Version 0.9 worked OK. Version 0.10.1 crashes with segmentation fault:

root@host3:~# ./certbot-auto --verbose
Root logging level set at 10
Saving debug log to /var/log/letsencrypt/letsencrypt.log
certbot version: 0.10.1
Arguments: ['--verbose']
Discovered plugins: PluginsRegistry(PluginEntryPoint#standalone,PluginEntryPoint#manual,PluginEntryPoint#nginx,PluginEntryPoint#webroot,PluginEntryPoint#apache,PluginEntryPoint#null)
Requested authenticator None and installer None
Segmentation fault (core dumped)

Log content produced is the same lines as above.

My operating system is (include version): Ubuntu 14.04.5
Virtual Machine (not a container) virtualized in a Proxmox x64 hypervisor.

My web server is (include version):

My hosting provider, if applicable, is:
Self hosted

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
ISPConfig3 (self installed)

Notes:
Version 0.9.x worked OK! This one just crashes :sweat:
After several failed installs, running

./certbot-auto certonly --standalone

worked ok and generate certificates. But this requires to stop apache service (to unbind TCP port 443)

Reading the forum, I noticed similar issues related to CFFI and gcc 5.3, mine is 4.8 so I guess this is not related.


#2

Hi @boriel,

I would recommend you post this information as an Issue on the Certbot repo.


#3

Thanks, @cpu ! :slight_smile:
Turns out that after doing apt-get upgrade today, several crypto libraries has updated and I can’t reproduce the issue anymore. Now it works like a charm! :blush:


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.