Can't see whats wrong here

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
I ran this command:
Request LE cert from Virtualmin panel
It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for
Using the webroot path /home/ for all unmatched domains.
Waiting for verification...
Challenge failed for domain
http-01 challenge for
Cleaning up challenges
Some challenges have failed.

  • The following errors were reported by the server:

    Type: unauthorized
    Detail: Invalid response from
    [2605:2700:0:2:a800:ff:feca:9922]: "\n\n404 Not

    Not Found


    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address.
    My web server is (include version):
    Apache 2.4.41
    The operating system my web server runs on is (include version):
    Ubuntu 20.04.2 LTS
    My hosting provider, if applicable, is:
    I can login to a root shell on my machine (yes or no, or I don't know):
    I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
    virtualmin 6.16
    The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):


Hi @bdamage, and welcome to the LE community forum :slight_smile:

Are you aware that name resolves to three IPs?

Addresses: 2605:2700:0:2:a800:ff:feca:9922

LE prefers IPv6 when present, so, as shown above, it will try IPv6 first (and will not fail-over to IPv4 when a response is provided by IPv6).
In this case, the response was negative and the authentication test failed.

Please ensure that your site works via IPv6 before continuing.


I agree with @rg305: your IPv6 address returns an "Apache Ubuntu Default Page" while your IPv4 address(es) respond with a small page saying "There's nothing here.".


Thanks very much. I just added the IP6 address and re requested. It all worked.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.