Cant reuse cert?


#1

Hi Everyone

i am quite new at this, and have successfully installed a certificate for my domain on my server, however i am in the need of changing this server to a new one, and are trying to assign the same certificate(for the same domain) to the new server, however i keep getting authorization errors, when recreating the certificat.

I have tried revoking it from the old server which seems to do nothing and no errors are thrown.

I have tried importing the entire /etc/letsencrypt folder into the new server and reinstalling a cert which also gives me authorization errors.

I am upgrading from a Raspberry pi to a raspberry pi 2 running apache.

So my question is how would i move my Letsencrypt Certificate from one server to another, i have access to both the new and old server and the private keys.

Could anyone help me get around this problem?

Regards


#2

The certificates themselves are basically text files, so I’d just copy it over from the old server to the new server. You shouldn’t need to revoke the certificate ( although if you have successfully revoked it, than you need to create a new one).

In the old server the apache config should point to the old certificates ( which you will need to copy over) You will then need to add them to the apache config on the new server (if the versions of apache are the same, you may just be able to copy over the apache site config file).


#3

Thanks for the tip serverco, it worked as it should, would this cause anytrouble whenever i need to renew the certificate?


#4

It shouldn’t cause any issues on renewal, no.