Can't renew my certificate, “ Error getting validation data”


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: kellertuer.spdns.org

I ran this command: many, e.g. certbot renew,
certbot renew --apache (which he didn’t recognise)
certbot renew --http
certbot to create a new one

It produced this output:
The server could not connect to the client to verify the domain :: Fetching http://kellertuer.spdns.org/.well-known/acme-challenge/[...removed...]: Error getting validation data. Skipping.

My web server is (include version): Apache2 (see below just apt-get updated but how do I find the version?)

The operating system my web server runs on is (include version): Raspberry Pi, Raspbian just updated (can’t find the number

My hosting provider, if applicable, is: (Pi is here at home)

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): I don’t know? I think not, I have SSH access?

First of all thanks for the awesome service, Let’s encrypt provides, I’ve had a certificate for a while now (it expired May 4th) but I am unable to renew it since May 5th (missed to do that before it ran out).

I tried a lot and read all Error getting validation Data threads available, tried deactivating my redirect to https in the apache config,…I don’t have a clue anymore what to look for.


#2

Hi,

It seems that your http port 80 was either filtered/not open/ misconfigured. Since only port 443 opens @port scan.

Please check your port settings since http-01 need to connect to http port 80 first then (can be redirect to https port 443).

Thank you


#3

Thanks – a little sad that such an easy note fixed it, but I wasn’t aware, that renew needed port 80 nor that I actually did not open port 80. As soon as I did, it worked :slight_smile: Thanks again!


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.