Cant renew certificate

Please fill out the fields below so we can help you better.

My domain is:

I ran this command: /usr/bin/certbot renew --quiet --renew-hook “/bin/systemctl reload nginx”

It produced this output: Attempting to renew cert from /etc/letsencrypt/renewal/ produced an unexpected error: Failed authorization procedure. (http-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from "

Lourdes College e-Learning <link rel="s". Skipping.

All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/ (failure)
1 renew failure(s), 0 parse failure(s)

My web server is (include version): nginx/1.12.0

The operating system my web server runs on is (include version): ubuntu 16.04

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

Expiry Date: 2017-08-06 01:07:00+00:00 (VALID: 15 days)

thank you

Just an FYI:
Addresses: 2400:cb00:2048:1::681f:5fad
2400:cb00:2048:1::681f:5ead resolves to multiple IPv6 and multiple IPv4 addresses.
Also, I think LE will prefer IPv6 over IPv4.

due to cloudflare settings…but i can revert back to the public ip of the server if you want to…still IPv4 though
but i already tested it and the certificate still won’t renew.

Ok, I don’t think CF would be a problem with http auth.
Try placing a test file at:
and see if it can be reached from the Internet - I suspect NOT.
Once that is working http auths should also work.

This may require the use of “–webroot” and “–webroot-path” parameters to work correctly and force use of http auth.

the link that you suggested can actually be seen…tried it…

so can i do this command?
certbot renew --quiet --renew-hook “/bin/systemctl reload nginx” --webroot /path --webroot-path /path/to/ ??

haven’t used this command yet…
am i correct?

Adding options like this to certbot renew is not quite the intended approach because that applies to all certificates that you have on your system (which for some people is many because they host many sites). The command that acts on a single certificate is certbot certonly, although you have to select the certificate to act on, normally with --cert-name.

Specifying your webroot directory is exactly the right idea here, but --webroot is just an abbreviation for --webroot-path, so you don’t need both of them. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.