Can't get my DNS Verified through Heroku

Please fill out the fields below so we can help you better.

My domain is: Discover.ly

I ran this command:
I recently transition to the get SSL through Heroku’s ACM service, but my service is show no SSL certificate and and my domains seem to be stuck in a DNS Verified state. They suggested you might have logic that is blocking. “I suspect that they think your domain is related to Discover Card, they probably have discover.* blocked. In order to resolve this issue, you’ll have to contact Let’s Encrypt directly about this issue. You can open a new inquiry with them on their Community Support site, they’ll have to provide further details about how to work on resolving this issue.”

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: register.ly & heroku

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

I think they’re saying that the name is blacklisted on Let’s Encrypt’s side. @cpu, could you look into this?

1 Like

Hi @tsumme,

Apologies about the difficulty you’re having & being bounced between support channels!

I’ve kicked off the process to allow issuance for discover.ly - this typically takes between 5 and 14 days to get fixed. I will notify you via this community forum thread as things progress. Thanks for your patience!

As an aside I hope that in the next few weeks I’ll have been able to enact a change that will reduce the number of these false positives and hopefully help avoid the problem outright for owners of domains like your own. I’m close to being done!

Thanks!

Thanks for the prompt response.

1 Like

Hi again @tsumme,

I’m told the fix has gone to production. Please let me know if you have any further difficulty issuing for discover.ly.

Thanks again for your patience!

Unfortunately, I’ve seen no progress. I’m still stuck in a DNS verified state.

Hi @tsumme,

It sounds like you need to tell Heroku support that we’ve resolved the policy issue at the Let’s Encrypt side. I checked the logs and nothing has tried to issue for discover.ly since I updated you yesterday to say that it should work. I suspect the Heroku system has your domain in a holding pattern since they aren’t aware the problem has been fixed yet.

Can you contact support and let us know what they say with this new information?

Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.