Can't get configure ssl for nginx

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

elderorb.tk / www.elderorb.tk

I ran this command:

sudo certbot --nginx -d elderorb.tk -d www.elderorb.tk

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for elderorb.tk
http-01 challenge for www.elderorb.tk
Waiting for verification…
Challenge failed for domain elderorb.tk
Challenge failed for domain www.elderorb.tk
http-01 challenge for elderorb.tk
http-01 challenge for www.elderorb.tk
Cleaning up challenges
Some challenges have failed.

IMPORTANT NOTES:

My web server is (include version):

nginx version: nginx/1.18.0 (Ubuntu)

The operating system my web server runs on is (include version):

Distributor ID: Ubuntu
Description: Ubuntu 20.04.1 LTS
Release: 20.04
Codename: focal

My hosting provider, if applicable, is:

self-hosted, but port 80 forwarded properly, http://elderorb.tk/.well-known/acme-challenge/something.html - is accessible

I can login to a root shell on my machine (yes or no, or I don’t know):

yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

1.8.0

Hi @ElderOrb

no, I can’t open your site. Same your check, ~~1,5 hours old - https://check-your-website.server-daten.de/?q=elderorb.tk#url-checks

Domainname Http-Status redirect Sec. G
http://elderorb.tk/ 93.125.104.84 -14 10.014 T
Timeout - The operation has timed out
https://elderorb.tk/ 93.125.104.84 -14 10.047 T
Timeout - The operation has timed out
http://elderorb.tk/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de 93.125.104.84 -14 10.014 T
Timeout - The operation has timed out
Visible Content:

Only timeouts.

A working port 80 is required, if you want to use http validation.

1 Like

Thanks for a good catch! I’ve tried using vpn and found this ‘public ip’ is public only when used from inside Belarus. :frowning: What is even more frustrating, my internet provider can do nothing about this and says its just fine on their side. Anyway, definitely not letsencrypt issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.