Problem with ssl

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: certbot --authenticator standalone --installer nginx -d --pre-hook “service nginx stop” --post-hook “service nginx start”

It produced this output: Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator standalone, Installer nginx
Running pre-hook command: service nginx stop
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for
Waiting for verification…
Cleaning up challenges
Running post-hook command: service nginx start
Failed authorization procedure. (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching Timeout


  • The following errors were reported by the server:

    Type: connection
    Detail: Fetching

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version): nginx service ver. 0.91-ubuntu1

The operating system my web server runs on is (include version): 16.04

My hosting provider, if applicable, is: DigitalOcean

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

You have an AAAA record but your server is not reachable over IPv6. Let’s Encrypt uses IPv6 for validation if you have an AAAA record so you need to either fix it or remove it.

(of course it’s nginx that can’t be reached right now, but I’m guessing certbot will have the same problem)

What is AAAA? Please, explain details how to fix it

It’s a record in your DNS. The A record points to your IPv4 address and the AAAA record points to your IPv6 address. If you don’t know how to fix it you can probably go into your DNS settings and remove it.

It’s better to fix IPv6 than to remove it. Could be a firewall issue.

Indeed it is, but I’m afraid I have no useful advice to offer in that regard :frowning:

man ip6tables for starters for example :stuck_out_tongue:

While this is technically true, it's also important to meet people where they are at. For instance, based on @96andi's question "What is AAAA?" you can probably guess that they would need to learn a lot about IPv6 and Internet routing to be able to diagnose and fix any issues they are having, and that man ip6tables is not sufficient guidance. I think in this situation, the most appropriate advice is "Visit your DNS provider's control panel and remove any AAAA records," with perhaps a link to a useful introduction to IPv6 if they want to learn more (sorry I don't have one handy). :slight_smile:

If i understand everything right, i must go into my provider and replace AAAA record into A record (Ipv6 into ipv4)?

If i understand everything right, i must go into my provider and replace AAAA record into A record (Ipv6 into ipv4)?

Do not modify the A record as that seems to be correct already.

You can remove the AAAA record entirely.

You said you’re on Digital Ocean, so if you want to try to fix IPv6 rather than removing it, I suppose their tutorials might be helpful? But removing the AAAA record should be sufficient to make Let’s Encrypt work (assuming of course that there are no other issues). You can recreate it later, when and if you’re confident that you have IPv6 working correctly.

Thanks for help, i create ssl. But now if i go i my site i see the next:

Your connection to this site is not fully secure.
attackers may be able to see the images you are looking at on this site…

You have some images loaded over HTTP, you need to change them to https:// URLs

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.