Can't get certificate

My domain is: fortwhat.com

I ran this command: sudo certbot --apache

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
No names were found in your configuration files. Please enter in your domain
name(s) (comma and/or space separated) (Enter ‘c’ to cancel): fortwhat.com
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for fortwhat.com
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. fortwhat.com (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://fortwhat.com/.well-known/acme-challenge/4Cp155NaesGJ3tbeTlEYo3SoGKByNAM5GH0T5zBpt_E [77.246.159.39]: “\n\n404 Not Found\n\n

Not Found

\n<p”

IMPORTANT NOTES:

My web server is (include version): Apache 2.4.29

The operating system my web server runs on is (include version): Ubuntu 18.04

My hosting provider, if applicable, is: ispserver.ru

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): ispmanager lite 5

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.31.0

1 Like

Did you configure your Apache for http://fortwhat.com/ in the first place? It seems certbot can’t handle your current Apache configuration.

Yes, I did, I configured it

Hi @MoXyLe

there is a check of your domain, ~~ one hour old - https://check-your-website.server-daten.de/?q=fortwhat.com

Looks like an incomplete configuration and / or a wrong port forwarding. Grade Q - http over port 443. But there is no older certificate.

That’s

bad. Your port 443 shows the standard Apache configuration page.

What says

apachectl -S
1 Like
apachectl -S

[Sun Dec 15 13:43:01.817313 2019] [alias:warn] [pid 28934] AH00671: The Alias directive in /etc/apache2/conf.d/letsencrypt.conf at line 1 will probably never match because it overlaps an earlier Alias.
VirtualHost configuration:
77.246.159.39:80 fortwhat.com (/etc/apache2/vhosts/www-root/fortwhat.com:1)
*:80 fortwhat.com (/etc/apache2/sites-enabled/000-default.conf:1)
ServerRoot: “/etc/apache2”
Main DocumentRoot: “/var/www/html”
Main ErrorLog: “/var/log/apache2/error.log”
Mutex default: dir="/var/run/apache2/" mechanism=default
Mutex mpm-accept: using_defaults
Mutex authdigest-opaque: using_defaults
Mutex watchdog-callback: using_defaults
Mutex rewrite-map: using_defaults
Mutex ssl-stapling-refresh: using_defaults
Mutex authdigest-client: using_defaults
Mutex ssl-stapling: using_defaults
Mutex ssl-cache: using_defaults
PidFile: “/var/run/apache2/apache2.pid”
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
Define: ENABLE_USR_LIB_CGI_BIN
User: name=“www-data” id=33 not_used
Group: name=“www-data” id=33 not_used

There

you see the problem. Two different vHost definitions with the same port and the same domain name.

Merge these in one. And don’t use ip:port, use always *:port.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.