Can't create a certificate || Too many requests - still can't

My domain is:

I ran this command:

certbot certonly --nginx -d
certbot certonly --nginx -d

It produced this output:

An unexpected error occurred:
There were too many requests of a given type :: Error creating a new order :: too many certificates (5) already issued for this exact set of domains in the last 168 hours:, retry after 2022-08-27T18:39:36Z: see Duplicate Certificate Limit - Let's Encrypt - And the same thing with

Problem: For me it is 19.26 now (UTC+2) and it said after 18:39:36 I can create another certificate, but I tried a few seconds ago and the same error occured, what timezone is the error message ment for, when can I create a new certificate?

My web server is (include version):
NGINX (newest)

The operating system my web server runs on is (include version):
Ubuntu 20.04

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

The timezone is indicated as Z (Zulu) which is UTC. Right now it is 18:22 UTC so not yet

EDIT: I have to ask ... why do you need so many certs? What is wrong with all the other (10+) valid ones you have gotten. See here:


Hello. Thank you for your fast answer!
To get to your question: I have two websites, and I made 5x a mistake (it's really hard), and I have to wipe my OS then, and therefore I have to create a new cert then, and I have to create the cert before I install the website, otherwise the website installation won't work. That might be a problem in the future, because I don't know when the installation will succeed.

1 Like

You can add --test-cert to that command which gets a test cert. That won't count against rate limits for the production system. When you access your website with it you will get a warning about the invalid test cert but you know it's a test so you can ignore that message.

Once you get everything working just remove --test-cert to get a real cert.

EDIT: Or, make a good backup of the letsencrypt folders and restore those after you rebuild your OS


Thank you very much! That helped me. :smiley:


Please back up any issued certificate before wiping anything in the future.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.