Cant Complete the setup process

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: sudo certbot --apache

It produced this output: The apache plugin is not working; there may be problems with your existing configuration.
The error was: NoInstallationError('Could not find configuration root')

My web server is (include version): * Apache/2.4.46 (cPanel)

The operating system my web server runs on is (include version): * CENTOS 7.9 kvm [server1]

My hosting provider, if applicable, is: Namecheap

I can login to a root shell on my machine (yes or no, or I don't know): Yes Via Terminal

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Am using Cpanel & WHM

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): cannot create user data directory: /home/uname/snap/certbot/793: Permission denied

Hi, and welcome to the LE community forum.

This indicates a problem with the Apache configuration.
I see that you are running cPanel (it should have handled this cert process for you).
So I don't know why you are having to run certbot manually.
Nonetheless, certbot should have worked.
Is it possible that anyone has also made changes to the Apache configuration manually?
Let's have a look at the basic Apache IP:port:FQDN assignments with:
sudo apachectl -S

the output is very long

You can....
Cut it and post it in pieces
Use a third party site - like paste.bin

But we really need to have a look at it.
I'm 99.9% sure the problem will be found there.

That was clever!

i actually want to set up SSL for all wildcards subdomains on my site like

I need it to cover both second level and third level subdomains

I didnt find an option in cpanel to do this,

Why would you want to do that?
It sounds very Phishy!

no, its not

take a look at

I am building a similar web analysis tool, so i will be having unlimited dynamic subdomains

back to the issue, how can i solve it

You have all your vhosts in the single file: /etc/apache2/conf/httpd.conf
[That makes things unnecessarily difficult - you should split them into individual files]

Anyhow, I find this same name in multiple places and some sections were included more than once:

port 80 namevhost (/etc/apache2/conf/httpd.conf:295)
port 80 namevhost (/etc/apache2/conf/httpd.conf:316)
: (/etc/apache2/conf/httpd.conf:346)
port 443 namevhost (/etc/apache2/conf/httpd.conf:6719)
port 443 namevhost (/etc/apache2/conf/httpd.conf:6719)
port 443 namevhost (/etc/apache2/conf/httpd.conf:6855)
port 443 namevhost (/etc/apache2/conf/httpd.conf:6855)
*:443 (/etc/apache2/conf/httpd.conf:6855)

Instead of this:

Can you just do this?:

oops, am new on terminal, i dont know how to clean that up
Is there no easier way to make it work?

You choose:
Basically undo whatever was done to make it that way (via menu options).
Fix it manually.

yes, i can do that , but its not how my competitors do it, they would outrank me on seo easily

please go easy , what menu options
I havent tampered with anything in my cpanel

Then you need to understand how wildcards work.
You can only cover one field with a wildcard.
And that must be the first one (left most).
So if you want:
You need a wildcard for:
You need a wildcard for:

Then you cut&pasted some sections in more than once.
So then there is no fix this by menu option.

yes, exactly what am trying to achieve

so what do you suggest i do
I can contact namecheap to assist me on my server end, but what do i tell them

I suggest we review the error message and try to fix whatever it needs:

It seems to want "configuration root".
Which it fails to find via normal process.
Luckily the docs show a way to pass it in the command line: