Can't access websites files or directories over https

I used Certbot-auto to create an ssl cert on my site. It worked beautifully, however now I can only access my index page via https and all other links redirect to that. I temporarily removed the htaccess to be sure this wasn’t having an impact. All links are visitable through http.

Domain:


Running ubuntu 18.04 on a Linode

1 Like

Works perfectly here. Perhaps you have some old redirects cached or something? Please clear your cache and try again. If it still doesn’t work, please show for example some screenshots or direct examples of misbehaving URI’s.

1 Like

Thanks for checking. So your comment just made me test out another browser. Site links work in chrome and Firefox but not safari… any thoughts? Clearing cache doesn’t help.

1 Like

No, I don’t use nor have Safari. Perhaps you can find some information online on how to debug in Safari. I’m sure it has a console of some kind.

1 Like

Thanks. I suppose I’d rather diagnose a browser-specific problem than restart Apache another 100x

1 Like

Hi @HAB

there is a check of your domain - ~~2,5 hours old - https://check-your-website.server-daten.de/?q=humansarebroken.com

Your certificate has only the non-www domain name.

CN=humansarebroken.com
	21.04.2020
	20.07.2020
expires in 90 days	humansarebroken.com - 1 entry 

So if someone uses the www version, that doesn’t work.

Create one certificate with both domain names, install that, recheck your domain. Then test, if Safari works. May be Safari has cached the www version.

Hi JuergenAuer

Thanks for responding. I was wondering if that would cause issues as well and am currently testing it out, I’ll let you know! (I had to create a new instance of it all from messing with too many settings, so this will take a bit)

Unfortunately I’m back where I started. Clicking around the site returns to the index. I’m not sure why. There’s no .htaccess at this point. I could click around before installing the ssl, but not after. Happens on all browsers now, mobile, etc. and even while browsing through the http version of the site via the ipaddress (173.255.245.136). Not sure what files could be changed to cause that.

Ok, a less tired version of me figured it out. It wasn’t letsencrypt or the ssl causing the issue directly, it was an unfortunate piece of code, browser caching, and then the ssl redirect that stimulated its reveal. If anyone else runs into this problem, get some sleep and come back.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.