Cannot renew Letsencrypt SSL certificate using cetbot

Hi guys,

Currently i cant access my website because of the SSL certificate has expired. I’ve tried to renew using certbot, but it give an error.

Cert is due for renewal, auto-renewing...
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for
nginx: [error] invalid PID number "" in "/var/run/"
Waiting for verification...
Challenge failed for domain
http-01 challenge for
Cleaning up challenges
Some challenges have failed.
 - The following errors were reported by the server:
   Type:   unauthorized
   Detail: Invalid response from
   []: "<html>\r\n<head><title>404 Not
   Found</title></head>\r\n<body>\r\n<center><h1>404 Not
   To fix these errors, please make sure that your domain name was
   entered correctly and the DNS A/AAAA record(s) for that domain
   contain(s) the right IP address.

I inherit this ERPNext system from previous staff that are no longer working with us.
It is highly appreciate if anyone could point me to the right direction.

Do let me know if you need any more information. Thanks

EDIT: There is actually automatic renew previously, but somehow this time around the auto renew failed.

My domain

I ran this command: ./certbot-auto

It produced this output: as Code snippet above

My web server is (include version): nginx version: nginx/1.10.3 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 16.04

My hosting provider, if applicable, is: DigitalOcean

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 1.3.0

You should think about upgrading that OS. (ie: reinstalling it)

That said, check your nginx configuration for that address, and your /etc/letsencrypt/renewal/whathever file

ps: this is not the full output.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.