Cannot install let's encrypt certificate manually on my server

I'm trying to install a ssl certificate on my domain hosted on IONOS, both manually and automatically, but I keep getting an error.

My domain is: www.linebreak.it

I ran this command: certbot certonly --manual

It produced this output:

Create a file containing just this data:

a1WBoKNjIrD_wXVpcLKEBcRNAO-Y5OfeAu2uESYXT9o.G7cKUyRa82BwbfaYG24muo32d_mhMDK5hSkG2dcIQiI

And make it available on your web server at this URL:

http://linebreak.it/.well-known/acme-challenge/a1WBoKNjIrD_wXVpcLKEBcRNAO-Y5OfeAu2uESYXT9o

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Press Enter to Continue          

Certbot failed to authenticate some domains (authenticator: manual). The Certificate Authority reported these problems:
  Domain: linebreak.it
  Type:   unauthorized
  Detail: 2001:4b78:1001::1201: Invalid response from http://linebreak.it/.well-known/acme-challenge/a1WBoKNjIrD_wXVpcLKEBcRNAO-Y5OfeAu2uESYXT9o: 404

Hint: The Certificate Authority failed to verify the manually created challenge files. Ensure that you created these in the correct location.

My web server is (include version): apache 2

The operating system my web server runs on is (include version): Ubuntu 22.04

My hosting provider, if applicable, is: IONOS

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No, but it used to run plesk, that I uninstalled.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 1.21.0

is your IPv6 address pointed to right host?

5 Likes

I don't have an IPv6

then should remove AAAA record from your domain

2001:4b78:1001::1201
7 Likes

yesss. it worked. Many thanks!

5 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.