Cannot install certbot: PPA name or format incorrect [solved]


#1

Following the instructions here:

When I get to the step to add the ppa …

I ran this command:
$ sudo add-apt-repository ppa:certbot/certbot

It produced this output:

Cannot add PPA: ‘ppa:certbot/certbot’.
Please check that the PPA name or format is correct.

The operating system my web server runs on is (include version):
Ubuntu 14.04.3


#2

It’s misleading, but add-apt-repository can say this if there is any sort of issue connecting to https://launchpad.net/.

For example:

  • Launchpad is down.
  • Your DNS resolver is broken.
  • Your clock is wrong.
  • Your HTTP proxy is malfunctioning.
  • You don’t have IPv4 connectivity.

Do you know of any issues? What happens if you run “wget https://launchpad.net/”?


#3

It seems in another thread you’ve confirmed that the problem is that your system couldn’t make DNS queries:


#4

Correct … once necessary domains were added to /etc/hosts I was able to proceed.

Now, to get the server admin to figure out that problem.

Thanks!


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.