Add-apt-repository Cannot add PPA

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: sudo add-apt-repository ppa:certbot/certbot

It produced this output: Cannot add PPA: ‘ppa:~certbot/ubuntu/certbot’.
The team named ‘~certbot’ has no PPA named ‘ubuntu/certbot’
Please choose from the following available PPAs:

  • ‘certbot’: Certbot PPA
  • ‘certbot-build’: Certbot Build PPA (don’t use this, use ppa:certbot/certbot)
  • ‘xenial-sru’: SRU packages for Xenial

My web server is (include version): Nginx 1.14.0-0ubuntu1.6

The operating system my web server runs on is (include version): Ubuntu Server 18.04

My hosting provider, if applicable, is: N/A

I can login to a root shell on my machine (yes or no, or I don’t know):Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):N/A

Following the instructions from , I see that ppa:certbot/certbot gets resolved into something more elaborate - ppa:~certbot/ubuntu/certbot and not sure about the implications. I’ve not used Linux for 17 years so I’m still very much learning the ropes of the Ubuntu distribution and its software installation system. cannot tell if that is a Ubuntu/apt problem or a certbot repository configuration problem?

Is this error still occurring for you? It is unusual and shouldn’t be happening - when I try from Ubuntu 18.04, it works okay.

Are you able to run the following successfully?

curl -X GET -I
$ curl -X GET -I
HTTP/1.1 200 OK
Date: Wed, 28 Aug 2019 08:22:26 GMT
Server: zope.server.http (HTTP)
X-Powered-By: Zope (, Python (
Content-Length: 99571
X-Xss-Protection: 1; mode=block
X-Content-Type-Options: nosniff
Strict-Transport-Security: max-age=15552000
Vary: Cookie,Authorization,Accept-Encoding
X-Launchpad-Revision: 19034
X-Frame-Options: SAMEORIGIN
Content-Type: text/html;charset=utf-8
X-Cache: MISS from banana
X-Cache-Lookup: MISS from banana:3128
Via: 1.1 banana (squid/3.5.12)

Now when I try it again, it appears to work.

$ sudo add-apt-repository ppa:certbot/certbot
[sudo] password for icelava:
 This is the PPA for packages prepared by Debian Let's Encrypt Team and backported for Ubuntu(s).
 More info:
Press [ENTER] to continue or Ctrl-c to cancel adding it.

Get:1 bionic InRelease [21.3 kB]
Hit:2 bionic InRelease
Get:3 bionic/main amd64 Packages [8,020 B]
Hit:4 bionic-updates InRelease
Get:5 bionic/main Translation-en [4,200 B]
Get:6 bionic-backports InRelease [74.6 kB]
Get:7 bionic-security InRelease [88.7 kB]
Fetched 197 kB in 3s (63.7 kB/s)
Reading package lists... Done

So what really did the initial error indicate? Is there something faulty with my server?


I don’t think there’s anything wrong with your server. I think there was probably some kind of temporary glitch with the Launchpad server, maybe the search index was stuffed up.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.