Cannot Execute request

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: payestaff.co.uk

I ran this command:

It produced this output:Getting challenge for payestaff.co.uk from acme-server…
User let’s encrypt key has been found, but not registered. Registering…
Account registration error. Response: HTTP/1.1 100 Continue
Expires: Mon, 27 Nov 2017 12:24:34 GMT
Cache-Control: max-age=0, no-cache, no-store
Pragma: no-cache

HTTP/1.1 400 Bad Request
Server: nginx
Content-Type: application/problem+json
Content-Length: 267
Replay-Nonce: GQ4oEHrHe_OzcdWmzdDybz4TyU_1c5k7ztvVlbM_7Zc
Expires: Mon, 27 Nov 2017 12:24:34 GMT
Cache-Control: max-age=0, no-cache, no-store
Pragma: no-cache
Date: Mon, 27 Nov 2017 12:24:34 GMT
Connection: close

{
“type”: “urn:acme:error:malformed”,
“detail”: “Provided agreement URL [https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf] does not match current agreement URL [https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf]”,
“status”: 400
}.

My web server is (include version): Apache ?

The operating system my web server runs on is (include version): ubuntu

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): no (using direct admin)

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): see above

I’m not familiar with direct admin
But the error seems to be with the TOS agreement being out of date.
This may be something that requires an update to the direct admin plugin for letsencrypt.

I agree with @rg305 This is probably caused by an old version of DirectAdmin.

Kinda stupid to hardcode something like this if you’d ask me. Or perhaps DirectAdmin has an option for the user to review the agreement? So it updates the accepted URL itself?

Ruling out any problem with Direct Admin, Tried to create cert using lets encrypt without using direct admin and got the same error.

I know Letencypt did an update on the 15th Nov which coincides with the error showing up. So, in seem to be an error created by Letsencypt rather than Direct Admin

So, what client did you use instead? There are some which are affected by hard coded TOS agreement URLs.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.