DirectAdmin Let's Encrypt plug-in


#1

Hi,

I have installed the Let’s Encrypt on my DirectAdmin server. Previously it worked well, but now I get the following error message when i create an SSL certificate in DirectAdmin:

Getting challenge for domain.ext from acme-server…
User let’s encrypt key has been found, but not registered. Registering…
Account registration error. Response: HTTP/1.1 100 Continue
Expires: Thu, 11 Aug 2016 13:48:23 GMT
Cache-Control: max-age=0, no-cache, no-store
Pragma: no-cache

HTTP/1.1 400 Bad Request
Server: nginx
Content-Type: application/problem+json
Content-Length: 265
Boulder-Request-Id: jCoCHLNI8GhZWqy0GJTIvUdC-4x_0By8lhKYPwC8Knk
Replay-Nonce: XtroLEuM7oRNaL-dDCTmOv967ShEFLhqR0prpmN6YOg
Expires: Thu, 11 Aug 2016 13:48:24 GMT
Cache-Control: max-age=0, no-cache, no-store
Pragma: no-cache
Date: Thu, 11 Aug 2016 13:48:24 GMT
Connection: close

{
“type”: “urn:acme:error:malformed”,
“detail”: “Provided agreement URL [https://letsencrypt.org/documents/LE-SA-v1.0.1-July-27-2015.pdf] does not match current agreement URL [https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf]”,
“status”: 400
}.

How can i solve this? Thanks!


#2

Hi @JochemPL

The Let’s Encrypt subscriber agreement was recently updated. This is a bug in the DirectAdmin plugin. It should be using the new subscriber agreement URL. Unfortunately I’m not familiar with DirectAdmin and can’t suggest a work around.

I would recommend you file a support issue with the maintainer of the DirectAdmin Let’s Encrypt plugin.


#3

I’m not using DirectAdmin, but if there is no fixed version yet, you could probably just patch it yourself. By the look of this: https://www.directadmin.com/features.php?id=1828, the script that does the job is placed in /usr/local/directadmin/scripts/letsencrypt.sh You can open it (making a copy just in case), find the string in question and replace it with a new one.

For example, it all can be done with the command like this:

perl -pi.bak -e “s/LE-SA-v1\.0\.1-July-27-2015/LE-SA-v1.1.1-August-1-2016/g” letsencrypt.sh

This would replace the agreement link with the recent one and created letsencrypt.sh.bak with the original content.

:warning: “Use with Caution” of course.


#4

Thanks! The problem is solved.


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.