Can not get certificate set up


#1

I am having an issue getting my certificate set up. I keep getting an "Invalid response from markernest.net/.well-known/acme-challenge.

I am running apache2 on Ubuntu.


#2

Hi,

I’m wondering where do you host your server… since that link lead me to godaddy’s url shortener page (w/ 404)

Fill in the below form please

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

Thank you


#3

Domain is markernest.net

Ran this command sudo cerbot --apache

I bought the domain at Godaddy. I am running the server locally. From the Godaddy site, I have set it to go to my local IP address.

I am running Ubuntu16.04LTS.

I have complete control of the server. For some reason the communication does not come back correct to my server when I try to set up the certificate. I am just not sure where I have erred.


#4

Can you copy and paste all of Certbot’s output?


#5

The reason is certbot does not follow that redirect since the URL redirector only works in 80, not 443… & You redirected to an IP address.

So, an easy option would be:

Setup the domain name to directly pointing to your server, instead of redirect through GoDaddy… & Setup the certificate w/ certbot directly to your server…

Thank you


#6

Thanks for the response. You did clear up the point that because it is being directed via GoDaddy andthat is where the problem lies.

As far as the domain name being directly pointed to my server, that is what I thought I was doing with the forwarding at GoDaddy, obliviously not, but I am unsure what I need to do to point the domain name in a different way.


#7

Please try to goto your control panel (domain DNS panel)… Create a.A record on @ & www, enter the public IP address of your server… then you are done.

An guide from GoDaddy:
https://www.godaddy.com/help/change-my-ip-address-20134

Thank you


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.