CAA record prevents issuance

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: jamespearson.xyz

I registered it once on this server, then I wiped it and installed a new OS, then I tried this certificate again, and I even used the same email address. Both of the old certificates were revoked before wiping.

I ran this command: certbot -v --apache

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache

Which names would you like to activate HTTPS for?
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
1: jamespearson.xyz
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter 'c' to cancel): 1
Requesting a certificate for jamespearson.xyz
Performing the following challenges:
http-01 challenge for jamespearson.xyz
Enabled Apache rewrite module
Waiting for verification...
Challenge failed for domain jamespearson.xyz
http-01 challenge for jamespearson.xyz

Certbot failed to authenticate some domains (authenticator: apache). The Certificate Authority reported these problems:
  Domain: jamespearson.xyz
  Type:   caa
  Detail: CAA record for jamespearson.xyz prevents issuance

Hint: The Certificate Authority failed to verify the temporary Apache configuration changes made by Certbot. Ensure that the listed domains point to this Apache server and that it is accessible from the internet.

Cleaning up challenges
Some challenges have failed.
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

My web server is (include version): Apache HTTP Server 2.4

The operating system my web server runs on is (include version): Ubuntu 20.04

My hosting provider, if applicable, is: Linode

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.20.0

1 Like

When I query this I get ""letsencrypt.org"" and you want "letsencrypt.org" instead, maybe you copied and pasted it.

5 Likes

Hi @JPcode05 and welcome to the LE community forum :slight_smile:

Revoking in that case is completely unnecessary (and rather a waste of such resources).

As for the CAA problem...
I would have to guess:

;; ANSWER SECTION:
jamespearson.xyz.       299     IN      CAA     1 issue "letsencrypt.org"
jamespearson.xyz.       299     IN      CAA     0 issue "trust-provider.com"

That the "1" might be part of the problem.
See: rfc6844
image

3 Likes

and there is some weird endian issue make that 0th flag is highest bit so critical flag only is 128

Note that according to the conventions set out in [RFC1035], bit 0 is the Most Significant Bit and bit 7 is the Least Significant Bit. Thus, according to those conventions, the Flags value 1 means that bit 7 is set, while a value of 128 means that bit 0 is set.

1 Like

Thanks for helping! I removed those fake quotes by just re-saving my settings, and now everything works!

3 Likes

I actually didn't need to do this, since I followed @webprofusion's tip instead, but thanks for the tip for in the future!

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.