Browser says certificate expired but certificate is valid

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
https://impactcloud-eu.sopact.com
I ran this command:

certbot certificates

It produced this output:

Found the following certs:
Certificate Name: impactcloud-eu.sopact.com
Domains: impactcloud-eu.sopact.com
Expiry Date: 2021-11-26 11:06:08+00:00 (VALID: 57 days)
Certificate Path: /etc/letsencrypt/live/impactcloud-eu.sopact.com/fullchain.pem
Private Key Path: /etc/letsencrypt/live/impactcloud-eu.sopact.com/privkey.pem

My web server is (include version):
Server version: Apache/2.4.43 (Amazon)

The operating system my web server runs on is (include version):

Amazon Linux 2

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):
Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
certbot 1.3.0

For some strange reason, even though my certificates are not expired, the browser says that it is expired and it happened all of a sudden yesterday.

Hi @madhukarsp, welcome to the LE community forum :slight_smile:
[and thank you for opening a separate topic]

Be sure that Apache is serving the full chain file:

It seems to be using only the cert.pem file:

---
Certificate chain
 0 s:/CN=impactcloud-eu.sopact.com
   i:/C=US/O=Let's Encrypt/CN=R3
---

Let me check this right away. Thanks for such a quick response. I will get back in a few minutes.

1 Like

Here is my config.

SSLCertificateFile /etc/letsencrypt/live/impactcloud-eu.sopact.com/cert.pem
SSLCertificateKeyFile /etc/letsencrypt/live/impactcloud-eu.sopact.com/privkey.pem
SSLCertificateChainFile /etc/letsencrypt/live/impactcloud-eu.sopact.com/chain.pem

Each of those points to

/etc/letsencrypt/live/impactcloud-eu.sopact.com/cert.pem -> ../../archive/impactcloud-eu.sopact.com/cert4.pem
/etc/letsencrypt/live/impactcloud-eu.sopact.com/privkey.pem -> ../../archive/impactcloud-eu.sopact.com/privkey4.pem
/etc/letsencrypt/live/impactcloud-eu.sopact.com/chain.pem -> ../../archive/impactcloud-eu.sopact.com/chain4.pem

Anything wrong here?

Yes:

That is a very old style of coding.
Change it to:
[only two lines required NOT three]

SSLCertificateFile /etc/letsencrypt/live/impactcloud-eu.sopact.com/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/impactcloud-eu.sopact.com/privkey.pem
#SSLCertificateChainFile /etc/letsencrypt/live/impactcloud-eu.sopact.com/chain.pem

image

3 Likes

@rg305 You are a savior. God sent! Thanks a ton. My problem is solved.

2 Likes

Glad to help :slight_smile:
Cheers from Miami :beers:

#FreeCUBA :cuba:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.