Boulder from 2016-11-07 fails to run under Docker


#1

I tried to run boulder from the latest tip, but I am getting an error when running the boulder container:

added users to boulder_sa_test
created all databases
WARNING: 'pkcs11_initialized' not true at rpc_C_Finalize
error: PKCS11 function C_Initialize failed: rv = CKR_FUNCTION_NOT_SUPPORTED (0x54)

Aborting.

Any clue?


#2

@fpoling have you run docker-rebuild.sh? I suspect you might have an older boulder-tools image locally.


#3

I tried to run docker build --rm --force-rm -t letsencrypt/boulder manually after killing all boulder-related containers. It did not help. This was under CoreOS and docker 1.10.


#4

Have you run docker-rebuild.sh? How are you starting the Boulder containers when they fail?


#5

Please ignore this. This was caused by incorrect merge that effectively removed PKCS11_PROXY_SOCKET from the boulder container. With a pristine tip everything works …


#6

Glad to hear you were able to sort it out. Thanks for the update!


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.