AWS:bitnami:MEAN, acme Error 403 Cannot GET /.well-known/


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: www.reasyshare.com

I ran this command:
sudo lego --email="touch410@hotmail.com" --domains=“www.reasyshare.com” --path="/etc/lego" run

It produced this output:
_ 2018/09/28 11:32:25 [INFO][www.reasyshare.com] acme: Obtaining bundled SAN certificate_
2018/09/28 11:32:25 [INFO][www.reasyshare.com] AuthURL: https://acme-v02.api.letsencrypt.org/acme/authz/zorUrp8yRkbO9EPuu14t0m14RtqVab8YxWxxtkkVDpo
2018/09/28 11:32:25 [INFO][www.reasyshare.com] acme: Trying to solve HTTP-01
2018/09/28 11:32:31 Could not obtain certificates
_ acme: Error -> One or more domains had a problem:_
[www.reasyshare.com] acme: Error 403 - urn:ietf:params:acme:error:unauthorized - Invalid response from http://www.reasyshare.com/.well-known/acme-challenge/DGU_5Bj90y1yLcli1gB7mrC19wn3a1mnzYiLx5DJQT8: “\n<html lang=“en”>\n\n<meta charset=“utf-8”>\nError\n\n\n

Cannot GET /.well-known/”

My web server is (include version): Apache/2.4.33

The operating system my web server runs on is (include version): Ubuntu 16.04.4 LTS

My hosting provider, if applicable, is: Amazon=>LightSail +Route53

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

Any help ,thanks!


#2

It’s solved . My bad. Since i setup 2 MEAN stack (per 2 virtual machines) , on machineA is the website running , on machineB , i’m excuting the lego. Too newbie!


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.