404 ERROR while accessing /.well-known/acme-challenge/

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: domain.com

I ran this command: certbot run -a manual -i nginx -d domain.com

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator manual, Installer nginx
Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for domain.com

NOTE: The IP of this machine will be publicly logged as having requested this
certificate. If you’re running certbot in manual mode on a machine that is not
your server, please ensure you’re okay with that.

Are you OK with your IP being logged?

(Y)es/(N)o: Y

Create a file containing just this data:


And make it available on your web server at this URL:


Press Enter to Continue
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. domain.com (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://domain.com/.well-known/acme-challenge/ObDi7dFxkof2meelMsLOdQIqZVrQnNiSxgktfhvskRA []: “\n\n404 Not Found\n\n

Not Found



My web server is (include version): Centos7

The operating system my web server runs on is (include version): Apache HTTP server

My hosting provider, if applicable, is: Hetzner

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Vesta

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.31.0

I have several domains on server and this is the first time when I face this issue.
I have created a folder /.well-known/acme-challenge/ inside web folder but cannot access it or any file inside - Error 404. Permissions are 755.
Please advise, thank you.

Hi! Welcome to the forum. Could you please provide your real domain name? It will be very hard for us to help you without it.

You can potentially try to ask Certbot to automatically resolve this issue for you:

certbot --nginx -d domain.com

but otherwise we need need your domain to give you any helpful advice.


Thank you Man, that solved the issue and necessity of manual configuration of NGINX.
Really appreciate your help.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.