AWS Bitnami installation blocking wordpress

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: sudo apt-get install certbot python-certbot-apache

It produced this output: apache overwrote our Wordpress instance

My web server is (include version): AWS Bitnami

The operating system my web server runs on is (include version):Debian10

My hosting provider, if applicable, is:AWS

I can login to a root shell on my machine (yes or no, or I don’t know): y

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):certbot-auto --version

1 Like


Bitnami uses a different Apache configuration and might start differently.

If you are using Bitnami on AWS, the best way to obtain a Let’s Encrypt certificate is using Bitnami suggested client, lego. The details can be found here:

In your case, you might need to reconfigure apache to use Bitnami configuration. I haven’t use Bitnami for a long time, but they have a page explaining their configuraion details.

I’m totally not familiar with Bitnami, but I’m also not sure how that’s possible. Is it wise to even use apt-get when using Bitnami? I read the Bitnami Apache configuration is even in a non-default location (/opt/bitnami/apache2/).

Perhaps you now have two Apache packages installed, conflicting with each other? Did you see if your command tried to install Apache again?

1 Like

yes, it looks like I now have 2 apache installs. I am completely new to Bitnami stack and AWS coming from IBM. Will try to uninstall the second instance. Hopefully I didn’t hose bitnami

The fact it’s even possible makes Bitnami a lousy piece of software IMHO… :roll_eyes:

So I definitely broke Bitnami. After uninstalling Apache 2, bitnami won’t load wordpress. :frowning:

My five cents: If you are planning to use one-click install for WordPress instance on AWS, the best (easiest) one you can find is probably Bitnami… (The fact it’s free, and has documentation w/ support portal)

Having restored a few WordPress instances, I can tell you that it’s all copy and paste in a chunk as far as the “install” goes, so you may be able to take one of your backup archives and just copy out the WordPress instance and paste it back in. There’s only a couple of configuration files at the root of the folder structure you’d even need to slightly modify if you’re using some kind of install manager. WordPress gives great instructions on this. Chances are that your install may have messed with the htaccess files and such.

Thank you for the help! I was able to edit a bitnami Apache config file and get everything back up and running. I’ve never had an SSL cert take down a site - lesson learned.

1 Like

Well, you weren’t that far yet :wink: This is more an incompatibility between all the custom #()(#) Bitnami pulls and the regular package manager apt which apparently can lead to installing certain incompatible packages twice.

Actually getting a TLS (SSL is an old name for the newer name TLS) certificate is a step further. For that, please read one of the Bitnami specific documents such as linked above.

What does ss -tlpn say? Anything on ports 80 or 443?

It’s already fixed:



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.