Auto Renewal/Dry Run not working


#1

Please fill out the fields below so we can help you better.

My domain is: kendallsecurity.ddns.net

I ran this command: ./certbot-auto renew --dry run

It produced this output:

Attempting to renew cert from /etc/letsencrypt/renewal/kendallsecurity.ddns.net.conf produced an unexpected error: Failed authorization procedure. kendallsecurity.ddns.net (http-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://kendallsecurity.ddns.net/.well-known/acme-challenge/EKLvQ7gEQiAq8Xcc4Efru1GZ_7egdbdwk6N2k5JodZE: "

Document Error: Not Found

Access Error: 404 -- Not Found

". Skipping.

------ However, these commands complete fine.----------------------

./certbot-auto certonly --webroot
./certbot-auto renew --force-renew

My operating system is (include version): CentOS6

My web server is (include version): httpd

My hosting provider, if applicable, is: Myself

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No


#2

Do you had redirections from port 80 to port 443?
If yes, try to start web server only on port 443 and try renewal.
This was my workaround yesterday, “cerbot renew” not worked but “cerbot renew --dry-run” yes.
I restarted the web server with only the server instances on port 443 and it worked.

Hope this help


#3

Yes, 443 and 80 are open…

Thanks…

Looks like ./certbot-auto renew --dry-run worked. I must have needed the “-” between dry and run.

Thanks!


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.