Authorization procedure fails


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
arbeitnehmerkasse.at

I ran this command:

sudo certbot certonly --webroot --agree-tos --email -d arbeitnehmerkasse.at -w /var/www/arbeitnehmerkasse.at/

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for arbeitnehmerkasse.at
Using the webroot path /var/www/arbeitnehmerkasse.at for all unmatched domains.
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. arbeitnehmerkasse.at (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://
arbeitnehmerkasse.at/.well-known/acme-challenge/yknp2iwNwzUq9Uh4MKEnCxozTq4OVpm8pBkKdOPaQHk: Timeout during connect (likely firewall problem)
IMPORTANT NOTES:

  • The following errors were reported by the server:
    Domain: arbeitnehmerkasse.at
    Type: connection
    Detail: Fetching
    http://arbeitnehmerkasse.at/.well-known/acme-challenge/yknp2iwNwzUq9Uh4MKEnCxozTq4OVpm8pBkKdOPaQHk:
    Timeout during connect (likely firewall problem)
    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version):
?

The operating system my web server runs on is (include version):
Ubuntu (16.04.4)

My hosting provider, if applicable, is:
Google Cloud

I can login to a root shell on my machine (yes or no, or I don’t know):
yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#2

Hi @J3012B

there is no webserver. If you use these options, certbot wants to load a file from

http://arbeitnehmerkasse.at/.well-known/acme-challenge/long-random-number

But http://arbeitnehmerkasse.at/ doesn’t work.


#3

Hi, thank you for your advice. How do you see this? Actually this domains points to an ip from a running web server. So, what should I do?


#4

I opend your link

http://arbeitnehmerkasse.at/

with my FireFox (Berlin). I can’t find a running webserver. Is there a firewall or something else?


#5

Hi @J3012B,

As @JuergenAuer said, or your webserver is not listening on port 80 (it actually listens on port 443) or there is a firewall blocking the connection to your server using port 80. The reason you didn’t notice it if you try to access http://arbeitnehmerkasse.de is because you configured your web server to send the Strict Transport Security header so your browser is always trying to reach that domain using https instead of http.

Cheers,
sahsanu


#6

@JuergenAuer

Using this command:

sudo ufw status

gives me this output:

Status: inactive

So, I guess there is no firewall running.

@sahsanu

CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
05049c91318b auko-nginx “nginx -g 'daemon of…” 7 days ago Up 3 hours 0.0.0.0:80->80/tcp, 0.0.0.0:443->443/tcp auko_gateway_1
84fb1bf8fc8e auko-webgui “nginx -g 'daemon of…” 7 days ago Up 3 hours 80/tcp auko_webgui_1

There are two docker container running: one on port 443 and one on 80. Do you have any suggestion on what I can do?

Greetings,
J3012B


#7

If you want to use a letsencrypt-certificate with http-01-challenge, then http://arbeitnehmerkasse.de/ must be available. It isn’t. So there is something else, which blocks the connection. https://arbeitnehmerkasse.de/ is there, but http is required. Same with http://www.arbeitnehmerkasse.de/

Because you are running a website (not a mailserver or something else), http should be open if someone types www.arbeitnehmerkasse.de without https. So you should fix that direct.


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.