Authorization Procedure Failed

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: plantnation.co.za

I ran this command: certbot --nginx

It produced this output:
Failed authorization procedure. www.plantnation.co.za (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://www.plantnation.co.za/.well-known/acme-challenge/np4qCfQwgUHwnB2WB-WQp6XXRxx9JW7twqRtGi8deTk [197.242.144.234]: “\n\n404 Not Found\n\n

Not Found

\n<p”

IMPORTANT NOTES:

My web server is (include version): nginx 1.10.3

The operating system my web server runs on is (include version): ubuntu 16.04

My hosting provider, if applicable, is: linode

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.31.0

I pointed two domains by means of changing the A records to my new server, plantlifesa.co.za and plantnation.co.za, after propagation I ran certbot for plantlifesa.co.za and it went through smoothly. When trying with plantnation.co.za I get the failed process. In the failed process where it shows the IP address, it for some reason shows the old server IP address. I have tried many times over many days since propagation and its still the same issue.

Im not sure why the authorization procedure is getting the wrong ip address?

Please assist.

Thanks,
Tay

Hi @tayzee

that’s the correct ip address. You have two different ip addresses and a wildcard - see https://check-your-website.server-daten.de/?q=plantnation.co.za

Host Type IP-Address is auth. ∑ Queries ∑ Timeout
plantnation.co.za A 139.162.225.245 London/England/United Kingdom (GB) - Linode, LLC Hostname: tayzee.xyz yes 1 0
AAAA yes
www.plantnation.co.za yes 4 4
www.plantnation.co.za A 197.242.144.234 Sandton/Gauteng/South Africa (ZA) - Afrihost (Pty) Ltd No Hostname found no
*.plantnation.co.za A 197.242.144.234 yes
AAAA yes
CNAME yes

The non-www is in London, the www in South Africa.

May be change the www and the wildcard entry if you run your client on the 139.* machine.

Hi Juergen,

Thanks so much for the quick response. So strange, for some reason in cpanel it shows me differently.

Anyway, ill take it up with the old hosting providers support.

Thanks again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.