Authenticator apache, Installer apache : name list incomplete

  • My domain is:
    https://domiciliostodoya.com
    SUbdomain for activating (i.e):
    https://todoya_v3.domiciliostodoya.com/

  • I ran this command: (for activating HTTPS subdomains cert)
    certbot --apache

but before: I’ve checked site is enabled and I got this link file on /etc/apache2/sites-enabled directory
todoya_v3.conf -> …/sites-available/todoya_v3.conf

  • It produced this output on certbot --apache command:
    ================================================
    Saving debug log to /var/log/letsencrypt/letsencrypt.log
    Plugins selected: Authenticator apache, Installer apache

Which names would you like to activate HTTPS for?


1: domiciliostodoya.com


Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter ‘c’ to cancel): c

  • PROBLEM IS:
    As you can see, only the main domain appears on list, but the subdomain name is not listed, any of them are not visible for selecting them and create respectivlely SSL certificatte

  • My web server is (include version):
    Apache

  • The operating system my web server runs on is (include version):
    Ubuntu 20.04 LTS

  • My hosting provider, if applicable, is:
    I am using Linode. VPS service

  • I can login to a root shell on my machine

I’m using a control panel to manage my site but almost all features via console.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
certbot 0.40.0

Any help?
Thanks at lot

Regards
Exel

1 Like

Is the subdomain a standalone virtualhost? What does this show:

apachectl -S
1 Like

Thanks really much for reply. I certainly new about VPS server managment and settings service indeed. Maybe I’ve ommited something. Again, I apreciate your help.

The output of command suggested is:

root@localhost:~# apachectl -S
AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using ::1. Set the ‘ServerName’ directive globally to suppress this message
VirtualHost configuration:
*:80 is a NameVirtualHost
default server ::1 (/etc/apache2/sites-enabled/000-default.conf:1)
port 80 namevhost ::1 (/etc/apache2/sites-enabled/000-default.conf:1)
port 80 namevhost apks.domiciliostodoya.com (/etc/apache2/sites-enabled/apks.conf:1)
alias apks.domiciliostodoya.com
port 80 namevhost domiciliostodoya.com (/etc/apache2/sites-enabled/domiciliostodoya.com.conf:8)
alias domiciliostodoya.com
port 80 namevhost todoya_v3.domiciliostodoya.com (/etc/apache2/sites-enabled/todoya_v3.conf:1)
alias todoya_v3.domiciliostodoya.com
port 80 namevhost todoya_v3_prod.domiciliostodoya.com (/etc/apache2/sites-enabled/todoya_v3_prod.conf:1)
alias todoya_v3_prod.domiciliostodoya.com
*:443 is a NameVirtualHost
default server apks.domiciliostodoya.com (/etc/apache2/sites-enabled/apks.conf:15)
port 443 namevhost apks.domiciliostodoya.com (/etc/apache2/sites-enabled/apks.conf:15)
alias apks.domiciliostodoya.com
port 443 namevhost domiciliostodoya.com (/etc/apache2/sites-enabled/domiciliostodoya.com-le-ssl.conf:2)
alias domiciliostodoya.com
port 443 namevhost todoya_v3.domiciliostodoya.com (/etc/apache2/sites-enabled/todoya_v3.conf:15)
alias todoya_v3.domiciliostodoya.com
port 443 namevhost todoya_v3_prod.domiciliostodoya.com (/etc/apache2/sites-enabled/todoya_v3_prod.conf:15)
alias todoya_v3_prod.domiciliostodoya.com
: ::1 (/etc/apache2/sites-enabled/webmin.1593118223.conf:1)
ServerRoot: “/etc/apache2”
Main DocumentRoot: “/var/www/html”
Main ErrorLog: “/var/log/apache2/error.log”
Mutex watchdog-callback: using_defaults
Mutex rewrite-map: using_defaults
Mutex ssl-stapling-refresh: using_defaults
Mutex ssl-stapling: using_defaults
Mutex ssl-cache: using_defaults
Mutex default: dir="/var/run/apache2/" mechanism=default
Mutex mpm-accept: using_defaults
PidFile: “/var/run/apache2/apache2.pid”
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
User: name=“www-data” id=33
Group: name=“www-data” id=33

Regards
Exel

1 Like

That looks okay.

There’s another problem that I did not initiallly notice. Underscores in certificate DNS names were fully banned back in 2018. As a result, are going to have to first rename your subdomain to something like todoya-v3-prod.domiciliostodoya.com.

Once you do that, you should be able to proceed with:

certbot --apache -d todoya-v3-prod.domiciliostodoya.com
1 Like

Wonderfull!!

That was all the problem. So I just had to rename sudomain name and not use “underscores” indeed. This solved my problem.

Thanks a lot, really thanks!

regards
Exel

1 Like