Attempt to gain SSL for LAMP webapp on centOS 6.5 with certbot

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: zitecraft-dev.cloud.tilaa.com

I ran this command: ./certbot-auto --apache

It produced this output: too many certificates already issued for this exact domain.

My web server is (include version): apache 2.2

The operating system my web server runs on is (include version): contOS 6.5

My hosting provider, if applicable, is: tilaa.nl

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

Hi. I first ran the certbot-auto setup which cause an error due to a missing "etc/httpd/conf.d/ directory, I created the dir manually ran the setup again and chose the two domains www.zite… and without www, (like before). this time i got a little further in the setup but the www domaine caused an error. I tried again this time without the www domain and got even a little further, but this time it seems that i have exceeded the amount of certificates ?

When i test my domain on sslabs it says that it found a certificate but doesn’t match the name, the certificate is issued to: localhost and issued by: localhost it looks to be very old, so i suspect it is a old certificate from a previous attempt

Yesterday i was trying to setup letsencrypt via directAdmin, but with kind of same result, at some point in my trying to make it work i ran into this “too many certificates already issued blabla…”

Will I have to wait until? tomorrow? next week? Are there anything else i can do to continue? I would really apreciate getting https up and running before the weekend. Cheers!
Rasmus

It wasn’t created by Certbot, for what it’s worth. Might’ve been created by DirectAdmin or your OS as a basic default.

https://letsencrypt.org/docs/rate-limits/

Well, the rate limit in this case is 5 duplicate certificates per week.

https://crt.sh/?q=zitecraft-dev.cloud.tilaa.com

The oldest certificate was created 2017-10-18 11:52; you’ll be able to create a new one 1 week from that time.

You can bypass the duplicate certificate rate limit by creating a certificate for zitecraft-dev.cloud.tilaa.com plus some other name. If there’s another name you can validate (e.g. test-test-test.cloud.tilaa.com, or any other domain you control), you can add that, and it will work.

(www.zitecraft-dev.cloud.tilaa.com doesn’t exist at the moment.)

If any of the certificates were created by Certbot, the necessary files should still exist in /etc/letsencrypt. ./certbot-auto certificates can list the certificates it’s currently managing; even if it’s not there, you can dig around in /etc/letsencrypt/archive and /etc/letsencrypt/keys for older files that may exist.

If they were all created by DirectAdmin… I don’t know where it places its files, or if it saves them permanently. Someone else may be able to chime in, or you can look around.

For current or future testing, you should use the staging environment, which issues untrusted certiificates but has higher rate limits. Certbot will use it if you pass the --staging argument; I don’t know if DirectAdmin supports it.

To help solve the underlying issues, could you provide the error messages you encountered, and maybe more information about the Apache configuration? We should be able to work out what’s going on with Certbot, but I’m not sure if there are any DirectAdmin experts here. It may be more fruitful to post on a DirectAdmin forum for that.

Thanks a lot, I will try to add -test to the domain if that is possible. and give it a shot again.
And maybe it is relevant to say, that i’m not trying to set ip up through DirectAdmin anymore, that was an attempt i did yesterday but was unhappy with the result, so now I’m trying with certbot instead.

Error message:

about the apache configuration i’m a bit green with that. which one of the following files is the right one?

locate httpd.conf
/etc/httpd/httpd.conf
/etc/httpd/httpd.conf_2.0
/etc/httpd/original/httpd.conf
/usr/local/directadmin/custombuild/configure/ap1/conf/httpd.conf
/usr/local/directadmin/custombuild/configure/ap2/conf/httpd.conf
/usr/local/directadmin/custombuild/configure/ap2/conf/httpd.conf_2.0
/usr/local/directadmin/data/templates/httpd.conf
/usr/local/directadmin/data/users/admin/httpd.conf

btw, I was following this guide: https://www.mervcodes.com/setup-lets-encrypt-free-ssl-certificate-centos-6-apache-using-certbot/

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.