Attempt at renewing shows success but certificate date not extended and less than 30 days left to expire

#1

I am currently running a virtual server and using Let’s Encrypt on 24 domains. On a regular basis the Let’s Encrypt service fails to update the existing certificate correctly. The control panel indicates success but the end result appears to be that the certificate is unchanged and the expiry date has not been extended. I have tried deleting the original certificate and then installing a new certificate. The end result is the same - the apparently new certificate start and end date is the same as the previously deleted certificate.

I have just tried again now:
nursingbydesign.com
Renew: Error message


Error installing certificate

Error_Installing_certificate:System.Web.Services.Protocols.SoapException: Server was unable to process request. —> System.Runtime.InteropServices.COMException: A specified logon session does not exist. It may already have been terminated. (Exception from HRESULT: 0x80070520) at MSPControl.Providers.Web.Iis.SSLModuleService80.HandleExceptionAndRollbackCertificate(X509Store store, X509Certificate2 x509Cert, SSLCertificate oldCert, WebSite webSite, String errorMessage, Exception ex) at MSPControl.Providers.Web.Iis.SSLModuleService80.InstallPfx(Byte certificate, String password, WebSite website) at MSPControl.Server.WebServer.installPFX(Byte certificate, String password, WebSite website) — End of inner exception stack trace —


Delete: Certificate successfully removed from the website
Installation of new certificate appears to have completed successfully through the Control Panel but the expiration date is unchanged.

I can see that in the Control Panel the date is in American format mm/dd/yyyy

I wonder whether this might be part of the issue? This appears to be set in MSPControl rather than regional server setting.

My domain is: nursingbydesign.com; nalbeta.nursing-agencies-list.com

I ran this command: MSPControl Auto and manual renew

It produced this output:

My web server is (include version): IIS 10

The operating system my web server runs on is (include version): MS Server 2016

My hosting provider, if applicable, is: WebWiz (www.webwiz.net)

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): MSPControl 1.0.0.6261

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): N/A?

#2

It seems to be an unresolved bug in MSPControl. If you have a paid licence with them, you might consider opening a support ticket with them directly.

As MSPControl is closed source, commercial software, there’s not much else we can do to assist you.

Of the three threads (1, 2, 3) that mention this issue, only one proposes a solution:

In order to resolve this I had to delete the Certificate from the server / website. Then delete the profile for the user and generate the certificate from the user again.

1 Like
#3

Hi @nigelfreeney

there is no new certificate created:

https://crt.sh/?q=www.nursingbydesign.com

The latest: 2019-01-08

The error is a standard problem. Happens, if the certificate doesn’t has a private key or if the private key is saved on the wrong place (personal store, not machine webhosting).

But an application should be able to handle that correct.

closed #4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.