[Solved] Unable to renew domain certificate under Windows 2008r2


I need some help in understanding how to renew site certificate on windows. When I run:

letsencrypt.exe --renew

I see that my certificate will expire on 2/28/2018. Nevertheless, when I am trying to access a resource on my site, the browser reports that my certificate already expired on 1/28/2018.

Can someone please help? Thanks


Do you have two certs?
Try using MMC to locate them and delete the expired.
And then use IIS to bind the good one.

Hi Rudy,

Thanks for response. I checked and you were right. The one that I have listed under MMC console in a certificate store has expired. Unfortunately, I don’t see the new one. Is there a way I can recreate it? Thanks


There isn’t much need to recreate a cert.
You could easier just create a new one.

While using MMC, be sure to check both user and computer certs.
you can try right click top of tree branch and “find cert”…

Can you please tell me how to recreate a certificate in MMC?



I tried using letsencrypt to generate new certificate in command prompt, but error:

I just copied this URL from command prompt into the browser and was able to load the content of the file successfully. Can you help me understand what am I doing wrong and what prevents this type of navigation and verification? Thanks


I did not mean to suggest that you could obtain a cert from the MMC.

Try placing a “test.txt” file within the acme-challenge folder.
Then you can verify accessibility from the Internet via the full URL.

Thanks. I used your suggestion and saw that there was an issue with routing which originated in my Firewall. Fixed that and everything is working now. Thank you.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.