Apache2 server Certbot Unable to find corresponding HTTP vhost

My domain is:
cocolino.top

I ran this command:
certbot --apache

It produced this output:
certbot --apache
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Unable to read ssl_module file; not disabling session tickets.

Which names would you like to activate HTTPS for?
We recommend selecting either all domains, or all domains in a VirtualHost/server block.


1: cocolino.top


Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter 'c' to cancel): 1
Certificate not yet due for renewal

You have an existing certificate that has exactly the same domains or certificate name you requested and isn't close to expiry.
(ref: /etc/letsencrypt/renewal/cocolino.top.conf)

What would you like to do?


1: Attempt to reinstall this existing certificate
2: Renew & replace the certificate (may be subject to CA rate limits)


Select the appropriate number [1-2] then [enter] (press 'c' to cancel): 1
Deploying certificate
Successfully deployed certificate for cocolino.top to /etc/apache2/vhosts.d/00_default_vhost-le-ssl.conf
Failed redirect for cocolino.top
Unable to set the redirect enhancement for cocolino.top.

NEXT STEPS:

  • The certificate was saved, but could not be installed (installer: apache). After fixing the error shown below, try installing it again by running:
    certbot install --cert-name cocolino.top

Unable to find corresponding HTTP vhost; Unable to create one as intended addresses conflict; Current configuration does not support automated redirection
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

My web server is (include version):
Server version: Apache/2.4.57 (Unix)

The operating system my web server runs on is (include version):
OS: Gentoo Linux x86_64
6.3.9-gentoo-dist

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):
yep

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
No, I am editing file in apache config.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
certbot 2.6.0

I can provide the contents of the apache2 configuration files if something needs to be changed there.
/var/log/letsencrypt/letsencrypt.log can be found here: View paste 6W232

[FIXED]

  1. On Gentoo "mod_ssl.so" is not located in "/etc/apache2/modules" but in "/usr/lib64/apache2/modules/mod_ssl.so". There isn't even a "/etc/apache2/modules" folder on Gentoo it is called "modules.d"!
    How I fix:
    -mkdir /etc/apache2/modules
    -cp /usr/lib64/apache2/modules/mod_ssl.so /etc/apache2/modules/mod_ssl.so

  2. I am embarrassed to say but I forgot to forward port 443 on my router, after that was done, no more errors. :flushed:

Note that the warning about "Unable to read ssl_module file; not disabling session tickets." doesn't have anything to do with the "Unable to find corresponding HTTP vhost; Unable to create one as intended addresses conflict; Current configuration does not support automated redirection" warnings.

It's kinda weird tho that Certbot did deploy the certificate correctly (so with that step there weren't any issues with address conflicts), but afterwards couldn't set up the redirect?

Your Apache configuration might be a little bit non-standard I believe.

4 Likes

I do my best to keep it standard, well as standard as you can on Gentoo.

True, but I run Gentoo too and I haven't seen this error before to be honest :slight_smile:

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.