Another issue with DSM connecting

Hi
As others before me I can't get an LE cert on my NAS.
My DDNS provider is noip.com, I have done the following after reading other posts of similar problems:
ports 80 and 443 are open, I've tried it with both Webstation running and without, I've made sure that my ISP only issues IPv4.
Multiple attempts without the command coming back with too many attempts (so most likely not connecting at all). Current installed cert is synology standard.

My domain is: laundrynas.ddns.net

I ran this command: Built-in synology function

It produced this output: Can't connect to Let's Encrypt, make sure domain is valid

The operating system my web server runs on is (include version): DSM 6.2 (Linux)

I can login to a root shell on my machine (yes or no, or I don't know): yes

all help much appreciated!!
H

1 Like

Hi @khalfdan

That's expected. Your port 80 doesn't answer, timeout. But your port 5000 answers (http), 5001 (https with a self signed).

But a working port 80 is required.

May be

  • change your port 5000 -> 80 (or)
  • add a port forwarding port 80 extern -> port 5000 intern
2 Likes

Oh dear, that is embarrassing. Sorry! I was 100% I had opened port 80, but I see I hadnt. Thank you!!

2 Likes

Happens :wink:

That's the reason to use (different) online tools. If online tools can't check your domain, Letsencrypt can't check your domain.

Happy to read you have found the problem :+1:

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.