Android app will not run, no_certificate

android app built about 3 years ago, will now not run in Android Studio due to INSTALL_PARSE_FAILED_NO_CERTIFICATES

I have tried all apparent fixes (clear cache, clean project, build new certificates, V1 and V2, etc.) but no go

what an I missing?

You might have better luck finding an answer on an Android app development forum than the Let's Encrypt community forums unless you're specifically have a problem with a Let's Encrypt certificate.


There are other FREE certificate providers and you could even try using a self-signed trusted cert.
If you can, try anyone of them and to see.

  • if the problem persists, it has nothing to do with LE.
    As suggested, try posting on an Android app dev forum
  • if the problem was resolved:
    a. Congrats!
    b. See if going back to LE resurrects the problem.
    [highly unlikely, but] If so, then LE would be interested in knowing more about this specific situation.

Thanks for the quick response, I have tried to find more on Android sites but no answer that works yet. I took a chance on LE due to this article I found - Many websites will stop working on older Android versions in 2021

It seemed similar enough to the problem I am seeing but I will ask around some more.

1 Like

I don't think that can be it, unfortunately, because your problem is with an app rather than with a connection from an Android device to a web site. So most likely the certificates in question aren't the same ones!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.