AlternativeNames issue

Hello Everyone,

I’m using Letsencrypt for the first time. Love it - what a great idea.

Letsencrypt was used by a former employee to install certificates for

The former employee set up a schedulled task to renew the certificates, it started to fail a while back, once the certificates were due to renew. Initially it was a problem with acme challenges.

I discovered that it was an Angular 2 site and added a rule so the acme challenges would work for the domains above.

Now when I run the following in a command prompt

letsencrypt.exe --renew --baseuri “” --verbose

The acme challenges are successful for each of the 4 combinations listed above, except it appears when a wildcard is encountered and then it just bombs out without giving any further info.

In the image below there is an AlternativeNames section and there is a * in it. This appears to lead to a failure in the certificates being renewed

This could be my lack of experience with Letsencrypt & domains so apologies if I’ve made an error. But why would their be a * in the alternative names? Why might this have worked for the former employee? Any ideas very much appreciated.




Please check your iis settings. There might be a iis with *

From your screen shot , line 9 (scanning iis sites) line 10 (added hosts *)

Thank you.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.