.acme.sh not using nc now uses socat tools / my question is where do I get these tools?

The command I ran was:
./acme.sh --test --renew -d le.domain.com

The error from the above was:
[Wed Sep 20 20:57:39 UTC 2017] le.domain.com:Verify error:Invalid response from http://le.domain.com/.well-known/acme-challenge/tEtlYiFnZ_2lYG6UkrwFm7W0E5ZIoSSJNJ0dHlqtzH0 [2605:de00:1:1:4a:2c:0:116]: 400

I then upgraded .acme.sh
with this command:
./acme.sh --upgrade

The above ran successfully.
new acme.sh version is 2.7.4

./acme.sh --test --renew -d le.domain.com
Only to get this error:
[Wed Sep 20 23:38:46 UTC 2017] Using stage ACME_DIRECTORY: https://acme-staging.api.letsencrypt.org/directory
[Wed Sep 20 23:38:46 UTC 2017] Renew: ‘le.domain.com
[Wed Sep 20 23:38:46 UTC 2017] Please install socat tools first.
[Wed Sep 20 23:38:46 UTC 2017] _on_before_issue.

So this is my Question: What are the socat tools and where do I get them?
Why aren’t they included with the acme.sh like nc?

Any help is appreciated!

Thank you

sudo apt-get install socat or sudo yum install socat

acme.sh didn’t include nc either; it’s just a text file. It’s just nc is a little more likely to be installed, but unfortunately the way nc works isn’t compatible with upcoming changes to way validation works so it had to be changed.


This is now resolved and when I get a moment I will post what my hosting company did to resolve this.
They installed the socat and provided the install instructions.

Below fix the socat issue:

To get socat installed the following worked for me, this was implemented by my hosting company webfaction.com
$ mkdir -p ~/src
$ cd ~/src
$ wget http://www.dest-unreach.org/socat/download/socat-
$ tar xfz socat-
$ rm socat-
$ cd socat-
$ ./configure --prefix=$HOME
$ make
$ make install
$ export PATH=$HOME/bin:$PATH

This fixed the certificate issue:
./acme.sh --issue -d le.doman.com -d le.www.domain.com -w /home/accountname/landing/le_challenge

I hope this helps

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.