Accidentally Deleted the TXT record while certificate renewal

My domain is:

I was trying to renew the certificate using this link. Was running through step 3 for renewal. I did not realize that I had to add new TXT records and replaced the values in the existing TXT records of the current certificate. Consequently, something went wrong. And then I tried again with step 3, it did not work. After a few failed attempts, I deleted the TXT records of the certificate entirely. Now, when I tried again, I am witnessing this error (screenshot attached).

I did not keep the backup of the values of the TXT record.

What should I do now?

Also, how long do I have to wait before I try again?


The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: AWS Lightsail

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.31.0


1 hour

There is a Failed Validation limit of 5 failures per account, per hostname, per hour. This limit is higher on our staging environment, so you can use that environment to debug connectivity problems. Exceeding the Failed Validations limit is reported with the error message too many failed authorizations recently . Rate Limits - Let's Encrypt

F*ck that tutorial that binds you to manual renewals.

This is the answer you're looking for:

It's not a good answer, but if you want a better one you need to use a dns authenticator plugin. (Or you might think a bit harder and maybe realize you don't actually need a wildcard, and automate all of it.)

ANYWAY, we go back to the shitty tutorial. I found the actual proper documentation on using let's encrypt certificates on bitnami apps. Read this:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.