A fresh noob needs help for its first certificate

it works for me: https://media.exstasi.ovh/

sonarr has a redirect loop though. you should look trough its settings or remove proxy_redirect off; from its config

server {

  #listen 80;
  server_name media.exstasi.ovh;
  access_log /var/log/nginx/media.exstasi.ovh.log;

  proxy_set_header X-Real-IP $remote_addr;
  proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
  #proxy_redirect off;
  proxy_set_header Host $host;

  location / {
      proxy_pass http://localhost:8010/;
      proxy_set_header X-Real-IP $remote_addr;
      proxy_set_header Host $host;
      proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
      proxy_set_header X-Forwarded-Proto $scheme;
      #proxy_redirect off;
      proxy_buffering off;
      }

  location /radarr {
      proxy_pass http://localhost:7878/;
      }

    listen 443 ssl; # managed by Certbot
    ssl_certificate /etc/letsencrypt/live/media.exstasi.ovh/fullchain.pem; # managed by Certbot
    ssl_certificate_key /etc/letsencrypt/live/media.exstasi.ovh/privkey.pem; # managed by Certbot
    include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
    ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

}
server {
    if ($host = media.exstasi.ovh) {
        return 301 https://$host$request_uri;
    } # managed by Certbot


  listen 80;
  server_name media.exstasi.ovh;
    return 404; # managed by Certbot


}

try

 location /radarr/ {
      proxy_pass http://localhost:7878//;
      }

and if it doesn’t work,

 location = /radarr { rewrite ^ /radarr/ redirect; }
 location /radarr {
      rewrite /radarr/(.*) /$1 break;
      proxy_pass http://localhost:7878/;
      }

(for the non-working ones.)

none worked
i came back to this

  location /radarr {
      proxy_pass http://localhost:7878/;
      }

#  location = /radarr { rewrite ^ /radarr/ redirect; }
#  location /radarr {
#      rewrite /radarr/(.*) /$1 break;
#      proxy_pass http://localhost:7878/;
#      }

#  location /radarr/ {
#      proxy_pass http://localhost:7878//;
#      }

if you login on the machine, does curl http://localhost:7878 produce any output?

nope nothing
I tried other apps like bazaar or sonarr, same result no output

on localhost? you need to start them, probably.

they are started for sure
good news

i tried this

  location ^~ /radarr {
      proxy_pass http://localhost:7878/radarr;
      }

it worked

1 Like