404 page not found, no motive stated

Please fill out the fields below so we can help you better.

My domain is:

I ran this command:
sudo ./certbot-auto --renew-by-default --debug -v --server https://acme-v01.api.letsencrypt.org/directory1 certonly -d www.footballtacticssimulator.com

It produced this output:
Root logging level set at 10
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Requested authenticator None and installer None
Apache version is 2.4.7
Multiple candidate plugins: * apache
Description: Apache Web Server plugin - Beta
Interfaces: IAuthenticator, IInstaller, IPlugin
Entry point: apache = certbot_apache.configurator:ApacheConfigurator
Initialized: <certbot_apache.configurator.ApacheConfigurator object at 0x7fc18d425c90>
Prep: True

  • standalone
    Description: Spin up a temporary webserver
    Interfaces: IAuthenticator, IPlugin
    Entry point: standalone = certbot.plugins.standalone:Authenticator
    Initialized: <certbot.plugins.standalone.Authenticator object at 0x7fc18c8d99d0>
    Prep: True

  • webroot
    Description: Place files in webroot directory
    Interfaces: IAuthenticator, IPlugin
    Entry point: webroot = certbot.plugins.webroot:Authenticator
    Initialized: <certbot.plugins.webroot.Authenticator object at 0x7fc18c8d9cd0>
    Prep: True

How would you like to authenticate with the ACME CA?

1: Apache Web Server plugin - Beta (apache)
2: Spin up a temporary webserver (standalone)
3: Place files in webroot directory (webroot)

Select the appropriate number [1-3] then [enter] (press ‘c’ to cancel): 3
Selected authenticator <certbot.plugins.webroot.Authenticator object at 0x7fc18c8d9cd0> and installer None
Enter email address (used for urgent renewal and security notices) (Enter ‘c’ to
Sending GET request to https://acme-v01.api.letsencrypt.org/directory1.
Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org
https://acme-v01.api.letsencrypt.org:443 “GET /directory1 HTTP/1.1” 404 19
Received response:
HTTP 404
Server: nginx
Content-Type: text/plain; charset=utf-8
Content-Length: 19
Boulder-Request-Id: XskYEkeTvAto-eOUz41PTNlRu80whL0GokKd6GL5c3o
X-Content-Type-Options: nosniff
Expires: Tue, 20 Jun 2017 08:54:19 GMT
Cache-Control: max-age=0, no-cache, no-store
Pragma: no-cache
Date: Tue, 20 Jun 2017 08:54:19 GMT
Connection: keep-alive

404 page not found

Exiting abnormally:
Traceback (most recent call last):
File “/home/ubuntu/.local/share/letsencrypt/bin/letsencrypt”, line 11, in
File “/home/ubuntu/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/main.py”, line 743, in main
return config.func(config, plugins)
File “/home/ubuntu/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/main.py”, line 667, in certonly
le_client = _init_le_client(config, auth, installer)
File “/home/ubuntu/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/main.py”, line 383, in _init_le_client
acc, acme = _determine_account(config)
File “/home/ubuntu/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/main.py”, line 368, in _determine_account
config, account_storage, tos_cb=_tos_cb)
File “/home/ubuntu/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/client.py”, line 158, in register
acme = acme_from_config_key(config, key)
File “/home/ubuntu/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/client.py”, line 44, in acme_from_config_key
return acme_client.Client(config.server, key=key, net=net)
File “/home/ubuntu/.local/share/letsencrypt/local/lib/python2.7/site-packages/acme/client.py”, line 71, in init
File “/home/ubuntu/.local/share/letsencrypt/local/lib/python2.7/site-packages/acme/client.py”, line 649, in get
self._send_request(‘GET’, url, **kwargs), content_type=content_type)
File “/home/ubuntu/.local/share/letsencrypt/local/lib/python2.7/site-packages/acme/client.py”, line 583, in _check_response
raise errors.ClientError(response)
ClientError: <Response [404]>
Please see the logfiles in /var/log/letsencrypt for more details.


My web server is (include version): Apache2

The operating system my web server runs on is (include version): Ubuntu 14.04

My hosting provider, if applicable, is: Instance on Amazon EC2

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

This was a second attempt to run an install, the previous code being;
sudo ./certbot-auto --debug -v --server https://acme-v01.api.letsencrypt.org/directory certonly -d footballtacticssimulator.com (failed because of missing www. for domain)

You used --server https://acme-v01.api.letsencrypt.org/directory1. The correct URL is https://acme-v01.api.letsencrypt.org/directory without the 1.

However, you don’t need to pass this option at all, as it is the default. In fact, it may break in the future as ACME v02 is launching this winter. :slight_smile:

Ah I see, I got my info from a notUltra recent turorial and I see you guys are changing things up quickly. Thanks for your response and time.

Just to check:

sudo ./certbot-auto --renew-by-default --debug -v certonly -d www.footballtacticssimulator.com

So this would be fine?

--renew-by-default forces renewal every time. It’s harmless right now though probably unnecessary if you’ve never had a certificate before. But, you should never put it in a crontab. Just use certbot-auto renew in your crontab so it will only renew 30 days out. (Some people recently have been getting a certificate every day until they hit their limit!)

OK thanks, I will take it out for now. Thanks again!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.