404 in HTTP challenge on Ubuntu 18

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: all of www.lilywise.com bidadance.org freeraisins.com www.beantownstomp.com kingfisherband.com regularlyscheduled.com www.felixcumming.com annakaufmanwise.com trycontra.com www.freeraisins.com www.bidadance.org lilywise.com beantownstomp.com jefftk.com www.trycontra.com www.olivercumming.com www.jefftk.com www.annakaufmanwise.com felixcumming.com www.regularlyscheduled.com www.kingfisherband.com

I ran this command:

$ sudo certbot certonly --nginx --dry-run

Earlier I was testing without --dry-run but then I hit limits and switched to staging as suggested by the docs.

It produced this output:

IMPORTANT NOTES:

163.172.164.150 is my VPS, as expected.

My web server is (include version):

$ nginx -V
nginx version: nginx/1.14.0 (Ubuntu)

The operating system my web server runs on is (include version):

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.4 LTS
Release: 18.04
Codename: bionic

My hosting provider, if applicable, is: n/a

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

$ certbot --version
certbot 0.27.0

1 Like

curl -Iki http://felixcumming.com/.well-known/acme-challenge/z-x-c
HTTP/1.1 302 Found
Server: nginx
Date: Sun, 21 Jun 2020 20:33:14 GMT
Connection: keep-alive
Location: https://www.felixcumming.com/.well-known/acme-challenge/z-x-c
X-Served-By: Namecheap URL Forward

1 Like

Name: felixcumming.com
Address: 192.64.119.155

Name: www.felixcumming.com
Address: 163.172.164.150

1 Like

Thanks! It looks like I’m using namecheap’s redirector for felixcumming.com -> www.felixcumming.com, and I’d forgotten that. I’ve removed it now; I’ll try certbot again after it propagates.

2 Likes

That fixed it, thanks!

2 Likes